Bug 16999 - pump can't rebind on a NACK
pump can't rebind on a NACK
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-27 05:08 EDT by ben.de.rydt
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 09:40:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ben.de.rydt 2000-08-27 05:08:18 EDT
dhcp.c tells it all:

/* This is somewhat broken. We try only to renew the lease. If we fail,
   we don't try to completely rebind. This doesn't follow the DHCP spec,
   but for the install it should be a reasonable compromise. */
int pumpDhcpRenew(struct pumpNetIntf * intf) {

This makes pump useless on the largest Belgian cable service provider
(Pandora),
because they rotate IP's every night.

Solution:
a) document the bug and make pump exit on failure and release the
interface, so I 
can at least do something like 
while ! ps ax | grep pump; do pump -i eth0; sleep 300; done
b) fix it :-)
Comment 1 Need Real Name 2000-09-12 16:09:56 EDT
My DHCP server is a Win2000 system, using the DHCP feature of "Internet 
Connection Sharing".
My RH6.2 client is rejected with a NACK message as well; and that happens all 
the time.
Might this be the same problem?
Comment 2 Elliot Lee 2001-07-19 18:10:17 EDT
dhcpcd replaces pump in rawhide and should be much more standards compliant.

Apologies for the unresponsiveness of the previous pump packager...

Note You need to log in before you can comment on or make changes to this bug.