Bug 1700046 - API server returns "Unauthorized" briefly during test runs, causes most flakes in e2e tests
Summary: API server returns "Unauthorized" briefly during test runs, causes most flake...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Auth
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.1.0
Assignee: Sally
QA Contact: Chuan Yu
URL:
Whiteboard:
: 1700052 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-15 16:51 UTC by Clayton Coleman
Modified: 2019-06-04 10:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:43 UTC

Description Clayton Coleman 2019-04-15 16:51:41 UTC
https://openshift-gce-devel.appspot.com/build/origin-ci-test/logs/release-openshift-origin-installer-e2e-aws-4.0/6733

https://www.dropbox.com/s/4smmx7wiyty2pjw/Screenshot%202019-04-15%2012.46.20.png?dl=0

^ all of the "waterfall" flakes there show Unauthorized at least once

Needs triage to a root cause, this is one of the "top failures" that impacts CI runs and general merge across the product.

Comment 1 Matt Rogers 2019-04-15 17:09:03 UTC
*** Bug 1700052 has been marked as a duplicate of this bug. ***

Comment 2 Matt Rogers 2019-04-15 19:51:25 UTC
We think that https://github.com/openshift/cluster-authentication-operator/pull/107 is the fix, so we are retesting and reviewing. Without this PR the cluster-authentication-operator can become Available even when the well-known endpoint check fails (we see "Progressing: got '404 Not Found' status while trying to GET the OAuth well-known https://172.30.0.1/.well-known/oauth-authorization-server endpoint data" before replicas come available), hence the tests failing on Unauthorized.

Comment 4 Chuan Yu 2019-04-19 05:22:56 UTC
Verified.

No such issue with nightly build now.

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.1.0-0.nightly-2019-04-18-210657   True        False         170m    Cluster version is 4.1.0-0.nightly-2019-04-18-210657

Comment 6 errata-xmlrpc 2019-06-04 10:47:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.