Bug 1700060 - kube-controller-manager target down due to incorrect port
Summary: kube-controller-manager target down due to incorrect port
Keywords:
Status: CLOSED DUPLICATE of bug 1698201
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Frederic Branczyk
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-15 17:33 UTC by Seth Jennings
Modified: 2019-04-16 07:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-16 07:02:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
kcm-down.png (81.24 KB, image/png)
2019-04-15 17:33 UTC, Seth Jennings
no flags Details

Description Seth Jennings 2019-04-15 17:33:44 UTC
Created attachment 1555288 [details]
kcm-down.png

See screenshot.

As of https://github.com/openshift/cluster-kube-controller-manager-operator/pull/207, metrics are served from the secure port 10257.

Result is a KubeControllerManagerDown and TargetDown alert.

We need to update the targets.

$ ogcv
NAME      VERSION                        AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.ci-2019-04-15-011801   True        False         3h45m   Cluster version is 4.0.0-0.ci-2019-04-15-011801

Comment 1 Seth Jennings 2019-04-15 17:41:54 UTC
I see there is already a PR for this:
https://github.com/openshift/cluster-monitoring-operator/pull/316

Comment 2 Seth Jennings 2019-04-15 18:19:21 UTC
This is also part of it
https://github.com/openshift/installer/pull/1576

Comment 3 Frederic Branczyk 2019-04-16 07:02:11 UTC
This is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1698201. Also components own their monitoring configuration, so please open a bug against the respective components next time. Thank you! :)

*** This bug has been marked as a duplicate of bug 1698201 ***


Note You need to log in before you can comment on or make changes to this bug.