Bug 170010 - Global install destroys /usr/share/info/dir
Global install destroys /usr/share/info/dir
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: global (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-06 11:01 EDT by Jerry James
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-06 14:00:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry James 2005-10-06 11:01:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
After upgrading to the new global package, /usr/share/info/dir contains only the entry for global.  All other entries were discarded.  Fortunately, the old dir file was saved as dir.rpmsave...

Version-Release number of selected component (if applicable):
global-4.8.7-1.fc4

How reproducible:
Didn't try

Steps to Reproduce:
1. Install the new global package
2. Examine /usr/share/info/dir
3.
  

Actual Results:  The dir file contained only the entry for global.

Expected Results:  The entry for global should have been added to the existing entries.

Additional info:
Comment 1 Gérard Milmeister 2005-10-06 13:59:23 EDT
Yes, a new build as already been made. Previous version didn't do this, I
only noticed it when I installed from the repository.
There seems to be a difference between FC3 and FC4. In FC3 /usr/share/info/dir is
overwritten and the old one saved. In FC4 the file is owned by the info
package and the installation fails with a warning.
Comment 2 Michael Schwendt 2005-10-07 10:18:19 EDT
"rm -f %{_datadir}/info/dir" in your package %install section to be safe.
Installation of info files creates that file when superuser is used.

Note You need to log in before you can comment on or make changes to this bug.