Bug 170022 - rhn-applet appears to be leaking memory
Summary: rhn-applet appears to be leaking memory
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rhn-applet   
(Show other bugs)
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Mihai Ibanescu
QA Contact: Beth Nackashi
URL:
Whiteboard:
Keywords:
: 69467 (view as bug list)
Depends On:
Blocks: 164831 168429
TreeView+ depends on / blocked
 
Reported: 2005-10-06 16:41 UTC by Adrian Likins
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version: RHBA-2006-0104
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 18:56:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0104 qe-ready SHIPPED_LIVE rhnlib bug fix update 2006-03-06 05:00:00 UTC

Comment 1 Robin Norwood 2005-10-07 15:42:54 UTC
*** Bug 69467 has been marked as a duplicate of this bug. ***

Comment 11 Mihai Ibanescu 2005-12-01 21:42:14 UTC
The leak does occur in RHEL4, it's just not as bad.

Should be fixed in rhnlib-1.8.2-1.p23.1

Comment 12 Clifford Perry 2006-01-05 15:50:19 UTC
New version of rhnlib is available as public beta on the Enterprise 4 channels
on RHN. 

rhnlib-1.8.2-1.p23.1.noarch   	 RHEL WS (v. 4 for x86) Beta
rhnlib-1.8.2-1.p23.1.noarch 	RHEL ES (v. 4 for x86) Beta
rhnlib-1.8.2-1.p23.1.noarch 	RHEL AS (v. 4 for x86) Beta
rhnlib-1.8.2-1.p23.1.noarch   	 Red Hat Desktop (v. 4 for x86) Beta

Comment 13 Beth Nackashi 2006-01-17 15:04:36 UTC
Verified memory usage stays stable and test passes on i386, ia64, and x86_64
with rhnlib-1.8.2-1.p23.1 and rhn-applet-2.1.22-4.

Ran rhn-applet-gui on i386, ia64, and x86_64 overnight and monitored memory
usage.  No issues.

PASSES_QA

Comment 15 Red Hat Bugzilla 2006-03-07 18:56:07 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0104.html



Note You need to log in before you can comment on or make changes to this bug.