Bug 170029 - remove .la files (and static libs), or package these separately
Summary: remove .la files (and static libs), or package these separately
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-06 17:37 UTC by Rex Dieter
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-20 09:16:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rex Dieter 2005-10-06 17:37:53 UTC
Please remove all %{_libdir}/lib*.la files from the package. 
This will reduce libtool/library bloat.

Further, it will (mostly) solve the problem of needing to install
extreneous packages(*) in order to build anything that uses subversion-devel.

(*) like libselinux-devel, beecrypt-devel, elfutils-devel

(mostly Library) packages with .la files of their own that
BuildRequires: subversion-devel
(probably) will need to be rebuilt after this modification.

If insist in still including the .la files (and static libraries), 
1.  please package them separately into something like subversion-static or
subversion-devel-static, so it would be possible to omit via
BuildConflicts
2.  The package that includes the .la files (if being kept, or being packaged
separately), needs to add Requires: to account for the library references in
said .la files, including (at least):
neon-devel (reference to /usr/lib/libneon.la)
krb-devel (references to -lgssapi_krb5 -lkrb5 -lk5crypto -lkrb5support)
db4-devel (reference to /usr/lib/libdb-4.3.la)
openldap-devel (reference to -lldap -llber)
expat-devel (reference to /usr/lib/libexpat.la)

Comment 1 Rex Dieter 2005-10-06 17:40:57 UTC
Oops, ignore my incorrect
(*) like libselinux-devel, beecrypt-devel, elfutils-devel
reference.  See (2) for the list of extraneous BR's.

Comment 2 Rex Dieter 2005-10-06 20:50:02 UTC
This one needs to be dealt with carefully.  

Just found that removing these .la files breaks at least one package: kdesdk. 
It tries to link against subversion using only -lsvn_client-1, and without the
livsvn_client-1.la file to list the extra libraries, yields undefined symbols. 
I would argue that this is a bug in kdesdk, since it technically uses
functions/symbols from libraries it's not directly linking against (and
depending on libtool to simply pull in everything). 

Comment 3 Joe Orton 2005-10-20 09:16:44 UTC
Well, quite.  You can't link against the libraries if those dependencies are
missing anyway, so I don't see what this gains.  WONTFIX, again.  The static
libs are already gone which removes the real bloat.


Note You need to log in before you can comment on or make changes to this bug.