Bug 170031 - expat: please omit *.la files, static libs
expat: please omit *.la files, static libs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: expat (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-06 13:43 EDT by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.95.8-7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-30 11:24:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2005-10-06 13:43:50 EDT
Please remove all %{_libdir}/lib*.la files and static libs from the -devel
package.  This will reduce libtool/library bloat.

Further, it will (mostly) solve the problem of needing to install
extreneous packages(2) in order to build anything that uses expat-devel.

(mostly Library) packages with .la files of their own that
BuildRequires: expat-devel
will need to be rebuilt after this modification.

If insist in still including the .la files (and static libraries), please
package them separately into something like expat-static or
expat-devel-static, so it would be possible to omit this extra crud in other
rpms that
BuildRequires: expat-devel
via
BuildConflicts: expat-devel-static
Comment 1 Rex Dieter 2005-10-06 13:47:37 EDT
Ignore my (incorrect) second statement regarding extraneous packages.  In this
case, there aren't any, since expat doesn't link against anything else.
Comment 2 Rex Dieter 2005-10-06 13:49:53 EDT
Upon further reflection (2) is partially correct, in that any other package
built using expat-devel, like subversion, if that package produces a -devel
package, it (the -devel) package will need a 
Requires: expat-devel
to account for the references to /usr/lib/libexpat.la in its own .la files. 
Comment 3 Joe Orton 2006-01-30 11:24:45 EST
libexpat.la dumped, libexpat.a is probably needed for statically-linked RPM still.

Note You need to log in before you can comment on or make changes to this bug.