Bug 1700337 - gsettings-desktop-schemas 3.32 breaks gala / mutter328 / Pantheon session
Summary: gsettings-desktop-schemas 3.32 breaks gala / mutter328 / Pantheon session
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gsettings-desktop-schemas
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1649555
TreeView+ depends on / blocked
 
Reported: 2019-04-16 10:42 UTC by Fabio Valentini
Modified: 2019-05-02 03:33 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-05-02 03:33:11 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github elementary gala issues 517 None None None 2019-04-16 10:42 UTC

Description Fabio Valentini 2019-04-16 10:42:53 UTC
Description of problem:

Launching gala (which is using the mutter328-libs compat package), results in this crash:

(gala:2197): GLib-GIO-ERROR **: 13:47:43.898: Settings schema 'org.gnome.desktop.peripherals.touchscreen' does not contain a key named 'display'

Followed by "Core dumped (segmentation fault)".

This issue popped up only recently, and it looks like gsettings-desktop-schemas moved around some stuff in gsettings schemas, which now breaks mutter328-libs, and hence gala, and the Pantheon Desktop completely ...


Version-Release number of selected component (if applicable):

- gsettings-desktop-schemas-3.32.0-1.fc30.x86_64
- mutter328-libs-3.28.3-6.fc30
- gala-0.3.1-0.23.20190307.git2c610b3.fc30


How reproducible:
Install Pantheon session on a clean install of fedora 30 workstation beta.


Steps to Reproduce:
1. install Pantheon Desktop
2. launch Pantheon Desktop from login screen
3. see WM / compositor crash

Actual results:
Pantheon Desktop Environment is unusable.


Expected results:
Desktop launches as expected.


Additional info:

This seems to be caused by item 2 in the gsettings-desktop-schemas release notes:

    Major changes in 3.31.0
    =======================
    - Add settings to inhibit microphone/camera
    - Change tablets'/touchscreens' "display" setting to "output" one
      with different semantics.
    - Added meson build support
    - Changed default clock settings
    - Added XF86Keyboard keybinding to cycle the keyboard layout

I don't know how I have to patch mutter328 to adapt to this change.

Comment 1 Fabio Valentini 2019-04-18 19:53:51 UTC
I found the line in mutter that triggers the issue:

https://gitlab.gnome.org/GNOME/mutter/blob/gnome-3-28/src/backends/meta-input-settings.c#L827

I don't know how to adapt this to the new "different semantics" mentioned in the gsettings-desktop-schemas release notes.

Comment 2 Jonas Ådahl 2019-04-19 06:15:33 UTC
Maybe you could try to backport parts of https://gitlab.gnome.org/GNOME/mutter/merge_requests/133/commits. At least the one that changes "display" to "output".

Comment 3 Fabio Valentini 2019-04-21 10:35:42 UTC
Well, I can at least try ... after I'm home from traveling on Tuesday.

Looking at the commits, backporting these changes to mutter 3.28 looks like it will be a bit too much for my meager C/GObject skills, but I will try, or ask somebody for help.

Comment 4 Fabio Valentini 2019-04-21 10:39:40 UTC
Though the easiest solution would probably be to patch gsettings-desktop-schemas downstream to keep the old "location" of the key name around for compatibility.

Comment 5 Fabio Valentini 2019-04-23 13:38:54 UTC
Nevermind, I backported the changes from the MR you linked.
The surrounding code didn't change too much, so it wasn't that hard.

Now I'm just hoping that it works :)

Comment 6 Fedora Update System 2019-04-23 14:45:28 UTC
mutter328-3.28.3-7.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-559c3c5c52

Comment 7 Fedora Update System 2019-04-24 20:27:47 UTC
mutter328-3.28.3-7.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-559c3c5c52

Comment 8 Fedora Update System 2019-05-02 03:33:11 UTC
mutter328-3.28.3-7.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.