Bug 170050 - please omit *.la files, static libs (or package them separately)
please omit *.la files, static libs (or package them separately)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: apr (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-06 16:19 EDT by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-20 04:44:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2005-10-06 16:19:08 EDT
pretty much the same arguments used in bug #170049

Please remove all %{_libdir}/lib*.la files and static libs from the -devel
package.  This will reduce libtool/library bloat.

Further, it will (mostly) solve the problem of needing to add
extreneous Requires: neon-devel to other (-devel) packages built against
neon-devel (to account for the references to /usr/lib/libapr.la in their own .la
files).

(mostly Library) packages with .la files of their own that
BuildRequires: neon-devel
will need to be rebuilt after this modification.  Notably subversion.

If you insist in still including the .la files (and static libraries), please
package them separately into something like apr-static.
Comment 1 Joe Orton 2005-10-20 04:44:07 EDT
The .la files are part of the APR interface and are needed by dependent
packages.  The .a archive is referenced from the .la files and I don't
particularly want to mess with that.  (APR cannot be e.g. built with
--disable-shared since the bundled libtool script needs to support both shared
and static libraries)

Note You need to log in before you can comment on or make changes to this bug.