Bug 170053 - Add udev rule for InfiniBand userspace access devices
Add udev rule for InfiniBand userspace access devices
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-06 16:32 EDT by Roland Dreier
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-15 08:24:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland Dreier 2005-10-06 16:32:40 EDT
The direct userspace access support included with the kernel's
InfiniBand drivers in kernels 2.6.13 and newer creates character
devices named uverbs0, uverbs1, etc.  Please add a udev rule:

    KERNEL="uverbs*", NAME="infiniband/%k", MODE="0660", GROUP="rdma"

to create the device nodes.

As you can see, I am suggesting that these nodes be owned by an "rdma"
group.  This is analogous to other groups used for device nodes, such
as "dialout" or "cdrom" -- the uverbs devices are fairly safe to allow
ordinary users access to, but an administrator should be able to
control which users can use the device.

I suggest the name "rdma" for the group name because these device
nodes give userspace programs access to RDMA capabilities from
InfiniBand and (someday) iWARP hardware.

Of course, this requires the creation of the rdma group.  I'm not sure
where or how this sort of group is managed, so please let me know if
there's any other avenues I should be sending this request to.
Comment 1 Harald Hoyer 2005-10-07 10:42:43 EDT
Which userspace apps?
Comment 2 Roland Dreier 2005-10-07 11:47:56 EDT
Apps will generally use this through an MPI library such as Open MPI
(http://open-mpi.org) or MVAPICH
(http://nowlab.cse.ohio-state.edu/projects/mpi-iba/).  These libraries access
InfiniBand through the libibverbs library, which I have packaged for Fedora
Extras (open request for review in bug 169743).

Note You need to log in before you can comment on or make changes to this bug.