Bug 17006 - Untranslated strings in usermode
Summary: Untranslated strings in usermode
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: usermode   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-27 17:21 UTC by Christian Rose
Modified: 2013-07-02 22:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-16 10:27:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christian Rose 2000-08-27 17:21:14 UTC
The "Exit" button caption in userinfo and usermount isn't translated in
RC2.

Tested with Swedish.

Comment 1 Nalin Dahyabhai 2000-08-28 16:19:28 UTC
This will be fixed in usermode-1.35-3 and later.

Comment 2 Christian Rose 2000-08-31 21:14:52 UTC
Also, the button captions "OK", "Cancel" and "Run Unprivileged" when running a
program that want's root privileges aren't translated (this tested with
usermode-1.35-1 on RH 6.2 with Swedish locale).

It might be worth to check all button caption code in all usermode apps so that
they get marked for translation properly (I don't know if you've done that,
reopening this bug in case this hasn't been checked).

Comment 3 Nalin Dahyabhai 2000-09-01 18:33:47 UTC
I got the literal strings the first time, which is why the button text got
missed.  I got the strings which were defined by the preprocessor the second
time around, so all user-visible strings should be marked for translation now.

Comment 4 Christian Rose 2000-09-01 19:36:09 UTC
Ok, like that "Format" button caption before. I guess that's the things that
happens when an app has to be gettextisized the first time around. :)

I guess this means that there will be some new messages for me in the i18n robot
soon...



Comment 5 Christian Rose 2000-10-16 10:15:34 UTC
I have RH7 with the usermode-1.36-3 update here.
None of the button captions in either of the programs are translated. I also,
just to make sure, checked the i18n robot for the Swedish usermode po file and
untranslated strings in it, but it is fully translated, and doesn't contain any
messages with the button captions.

Reopening this.

Comment 6 Christian Rose 2000-10-16 10:28:58 UTC
Also, the message

#: ../userhelper-wrap.c:345
#, c-format
msgid ""
"In order to run \"%s\" with %s's privileges, additional information is "
"required."

seems to mysterically be shown in English again. In previous versions, it was
shown in Swedish, and the Swedish translation still exists in the i18n robot.

All this is truly weird. I've come to believe that either is the i18n robot out
of touch with reality (out of touch with cvs), or the usermode-1.36-3 update
based on a month-old cvs fork. Either way, it should probably be fixed.

Comment 7 Christian Rose 2000-11-03 21:36:08 UTC
Bug is still present in the usermode-1.37-2 package I got today.

Comment 8 Kjartan Maraas 2004-08-30 00:33:19 UTC
Looks like this has been fixed a long time ago? Close?

Comment 9 Jindrich Novy 2004-09-16 10:27:04 UTC
Hello Christian,

is looks like everything is now translated properly, closing this.

cheers,
Jindrich


Note You need to log in before you can comment on or make changes to this bug.