Bug 170063 - Lock manager failure at boot time.
Lock manager failure at boot time.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lvm-obsolete (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Heinz Mauelshagen
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-06 17:53 EDT by Erik P. Olsen
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-26 09:21:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik P. Olsen 2005-10-06 17:53:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7

Description of problem:
Getting following message at boot time:
"Setting up Logical Volume Management:  /var/lock:  mkdir failed: Read-
only filesystem."
Reason is probably that /var is a separate partition which is "read only" at boot time. Therefore no lock can be held until the partition is set to "read/write" mode.

Version-Release number of selected component (if applicable):
kernel 2.6.13-1.1526_FC4

How reproducible:
Always

Steps to Reproduce:
1. Create a Fedora Core 4 system with /var as separate partition
2. Boot the system
3.
  

Actual Results:  Following message is displayed:
"Setting up Logical Volume Management:  /var/lock:  mkdir failed: Read-
only filesystem."

Expected Results:  No error message.

Additional info:

Since FC3 does not have this bug, maybe then the FC3 method of serialising the process should be retrofitted into FC4.
Comment 1 Milan Broz 2006-04-26 09:21:39 EDT
Dmraid must be called with --ignorelocking in initscripts, see bug 168195.

Note You need to log in before you can comment on or make changes to this bug.