Bug 1700730 - [UPDATE] undercloud update fail with nested exceptions
Summary: [UPDATE] undercloud update fail with nested exceptions
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-rabbitmq
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 15.0 (Stein)
Assignee: Sofer Athlan-Guyot
QA Contact: Raviv Bar-Tal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-17 09:27 UTC by Raviv Bar-Tal
Modified: 2019-09-26 10:49 UTC (History)
13 users (show)

Fixed In Version: puppet-rabbitmq-9.0.1-0.20190507085104.7613f08.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:21:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
uc update errors (124.04 KB, text/plain)
2019-04-17 13:43 UTC, Raviv Bar-Tal
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github voxpupuli puppet-rabbitmq issues 783 0 None closed Fact rabbitmq_plugins_dirs can crash the puppet run 2020-09-25 05:12:20 UTC
Launchpad 1821017 0 None None None 2019-04-29 15:31:48 UTC
RDO 20492 0 None None None 2019-04-29 15:34:43 UTC
RDO 20493 0 None None None 2019-04-29 15:54:50 UTC
RDO 20495 0 None None None 2019-04-29 17:12:56 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:21:35 UTC

Description Raviv Bar-Tal 2019-04-17 09:27:34 UTC
Description of problem:
undercloud update fails, 
The log contains lots of Warnings like:

"Warning: The function 'hiera' is deprecated in favor of using 'lookup'. See https://puppet.com/docs/puppet/5.5/deprecated_language.html\\n   (file & line not available)"

"Warning: /etc/puppet/hiera.yaml: Use of 'hiera.yaml' version 3 is deprecated. It should be converted to version 5",

"Warning: Undefined variable '::deploy_config_name'; \\n   (file & line not available)",

"Warning: ModuleLoader: module 'openstacklib' has unresolved dependencies - it will only see those that are resolved. Use 'puppet module list --tree' to see information about modules\\n   (file & line not available)"


AND at the end, it fails with:

1. "Exception: Deployment failed
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/tripleoclient/v1/tripleo_deploy.py", line 1256, in _standalone_deploy
    raise exceptions.DeploymentError('Deployment failed')
tripleoclient.exceptions.DeploymentError: Deployment failed
None "

2."During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/tripleoclient/command.py", line 30, in run
    super(Command, self).run(parsed_args)
  File "/usr/lib/python3.6/site-packages/osc_lib/command/command.py", line 41, in run
    return super(Command, self).run(parsed_args)
  File "/usr/lib/python3.6/site-packages/cliff/command.py", line 184, in run
    return_code = self.take_action(parsed_args) or 0
  File "/usr/lib/python3.6/site-packages/tripleoclient/v1/undercloud.py", line 178, in take_action
    raise exceptions.DeploymentError(e)"

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. install osp15
2. update python3-tripleoclient* openstack-tripleo-common openstack-tripleo-heat-templates
3. run openstack undercloud upgrade

Actual results:
update failed

Expected results:


Additional info:

Comment 1 Raviv Bar-Tal 2019-04-17 13:43:29 UTC
Created attachment 1555908 [details]
uc update errors

Comment 2 Lukas Bezdicka 2019-04-18 13:35:04 UTC
        "Error: Facter: error while resolving custom fact \"rabbitmq_plugins_dirs\": undefined method `[]' for nil:NilClass",

Comment 3 Sofer Athlan-Guyot 2019-04-29 15:34:44 UTC
This is fixed upstream, currently waiting on a new build in rdo to get it into downstream puddle.

Comment 14 errata-xmlrpc 2019-09-21 11:21:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.