Bug 170080 - KDE power config complains about klaptop_acpi_helper
KDE power config complains about klaptop_acpi_helper
Product: Fedora
Classification: Fedora
Component: kdeutils (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2005-10-06 21:30 EDT by Dan Christian
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: kdeutils-3.5.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-17 17:53:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dan Christian 2005-10-06 21:30:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
If you try to configure /usr/bin/klaptop_acpi_helper from the kde power control panel (ACPI Config tab), it complains that the "application does not seem to have the same size or checksum as when it was compiled"...

rpm --verify doesn't show any descrepancies.

If you continue and set SUID root, it refuses to use the helper.

This make suspend impossible from kde.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Right click on KLaptop in the panel.  Select Configure KLaptop.
2.Select the ACPI Config tab
3.Click Setup Helper Application

Actual Results:  Error dialog comes up.

Expected Results:  Prompt for root password.

Additional info:

I'm running on a Dell Latitude C400.

I had suspend working under KDE with FC2.  So the hardware/firmware should work OK.
Comment 1 Muyi Taiwo 2005-10-24 06:06:48 EDT
An identical problem also happens on a Toshiba (Tecra?) TE2000.  Suspend worked
under (and works when I boot using) kernel 2.6.11, but does not work under
2.6.12 or 2.6.13_1.1526.
This seems to be the same bug as 135623 which apparently has been fixed in
kdeutils-3.4.2-2, available in Rawhide, but for some reason not in FC4.
Comment 2 Christian Iseli 2007-01-22 05:24:31 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Comment 3 Rex Dieter 2007-11-17 17:53:05 EST
closing, no feedback.

Note You need to log in before you can comment on or make changes to this bug.