Bug 1700807 - rear is missing additional path for NBU_LD_LIBRARY_PATH
Summary: rear is missing additional path for NBU_LD_LIBRARY_PATH
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rear
Version: 7.6
Hardware: Unspecified
OS: Unspecified
urgent
medium
Target Milestone: rc
: 7.8
Assignee: Pavel Cahyna
QA Contact: David Jež
URL:
Whiteboard:
Depends On:
Blocks: 1122832 1746150 1747393
TreeView+ depends on / blocked
 
Reported: 2019-04-17 12:06 UTC by Oliver Falk
Modified: 2020-03-31 20:07 UTC (History)
7 users (show)

Fixed In Version: rear-2.4-10.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1746150 1747393 (view as bug list)
Environment:
Last Closed: 2020-03-31 20:06:59 UTC
Target Upstream Version:
ofalk: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github rear rear issues 2105 'None' closed NBU libs in /usr/openv/netbackup/sec/at/lib not included 2020-08-18 13:17:40 UTC
Github rear rear pull 2122 'None' closed Address issue https://github.com/rear/rear/issues/2105 2020-08-18 13:17:40 UTC
Red Hat Product Errata RHBA-2020:1153 None None None 2020-03-31 20:07:39 UTC

Description Oliver Falk 2019-04-17 12:06:38 UTC
Description of problem:

rear reports missing libs:

    There are binaries or libraries in the ReaR recovery system that need additional libraries
    /usr/openv/lib/plugins/libauthpam_t.so requires additional libraries
            libvrtsat_t.so => not found


Version-Release number of selected component (if applicable): 4.2


How reproducible: Always.


Steps to Reproduce: n/a

Actual results: rear reports missing libs, when using Netbackup


Expected results: rear shouldn't report missing libs when using Netbackup


Additional info:
Customer case will be linked in a hurry.
I already made sure this is fixed upstream - it's already merged on master ([1]), we 'just' need to rebase our rear package.


[1] https://github.com/rear/rear/issues/2105

Comment 2 Pavel Cahyna 2019-04-17 12:22:20 UTC
Possibly related fixes: bz1652853 bz1652828

Comment 3 Oliver Falk 2019-04-17 12:28:33 UTC
Pavel, so my fix upstream is going to fix 3 downstream bugs :-)

Comment 4 Pavel Cahyna 2019-04-17 13:25:35 UTC
The other two bugs are already fixed, but I wonder what is the status of Netbackup support with those two fixes and without this one. Renaud, is Netbackup support usable in any way without this fix?

Comment 5 Renaud Métrich 2019-04-18 11:28:22 UTC
Hi Pavel,

I was not aware of that issue, but apparently this is also needed, maybe it depends on the NetBackup version being used.

Comment 6 Pavel Cahyna 2019-06-27 13:04:21 UTC
Oliver, do you please know what NBU version is and is not affected? It would be helpful for the release notes.

The bug was reported too late for 7.7, but we will consider it for inclusion in 7.8.

Comment 7 Oliver Falk 2019-06-28 10:54:51 UTC
Hi Pavel!

If I check the sosreport, I'd say it's 8.0? =>

    # grep VRTSnetbp installed-rpms |cut -f1 -d " "
    VRTSnetbp-8.0.0.0-1478763912.x86_64

Oliver

Comment 20 errata-xmlrpc 2020-03-31 20:06:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1153


Note You need to log in before you can comment on or make changes to this bug.