Bug 1700828 - Sporadic kube-apiserver NLB connection refused response
Summary: Sporadic kube-apiserver NLB connection refused response
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Stefan Schimanski
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-17 12:54 UTC by Stefan Schimanski
Modified: 2019-06-04 10:47 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:50 UTC

Description Stefan Schimanski 2019-04-17 12:54:47 UTC
Description of problem:

In CI we occasionally see connection refused when connecting through the NLB to the kube-apiserver. With /readyz used as NLB target health check and our timing (35 sec kube-apiserver minimum-termination-period, 3*10 sec NLN target unhealthz threshold) this should never happen.

Version-Release number of selected component (if applicable):

4.10

How reproducible:

Randomly in CI.

Additional info:

Comment 5 errata-xmlrpc 2019-06-04 10:47:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.