Bug 1700903 - standardize resource names for auth api's
Summary: standardize resource names for auth api's
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Auth
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Erica von Buelow
QA Contact: Chuan Yu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-17 15:45 UTC by Erica von Buelow
Modified: 2019-06-04 10:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:55 UTC

Description Erica von Buelow 2019-04-17 15:45:11 UTC
Description of problem:
- remove "openshift-" prefix from the resource names for auth components

!!!BLOCKS API FREEZE!!!

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Run:
- `oc get all -n openshift-authentication`
- `oc get all -n openshift-authentication-operator`
- `oc get all -n openshift-service-ca`
- `oc get all -n openshift-service-ca`
2. Resource names displayed should be informative and short.

Actual results:

Many resources with the name "openshift-authentication" for instance

Expected results:

Something like "oauth-server" for the service name.

Additional info:

Comment 3 Chuan Yu 2019-04-24 02:57:11 UTC
The 4.1.0-0.nightly-2019-04-23-223857 not include this fix.

$ oc adm release info --pullspecs registry.svc.ci.openshift.org/ocp/release:4.1.0-0.nightly-2019-04-23-223857 | grep authentication-operator
  cluster-authentication-operator               quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:49d3cdc25ca76078f49e040a775c8b3ddc6dab6fb67bc3cfe0318609c3b28b99

$ oc image info quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:49d3cdc25ca76078f49e040a775c8b3ddc6dab6fb67bc3cfe0318609c3b28b99 | grep commit.url
             io.openshift.build.commit.url=https://github.com/openshift/cluster-authentication-operator/commit/b22c05adbfea7c899757355f79d34f7a93525b46

Comment 4 Chuan Yu 2019-04-25 08:19:03 UTC
Verified.

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.1.0-0.nightly-2019-04-25-002910   True        False         5h22m   Cluster version is 4.1.0-0.nightly-2019-04-25-002910

Comment 6 errata-xmlrpc 2019-06-04 10:47:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.