Bug 170097 - NFS server exporting wrong filesystem
NFS server exporting wrong filesystem
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nfs-utils (Show other bugs)
4.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-07 03:47 EDT by Mikael M. Hansen
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-21 08:37:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikael M. Hansen 2005-10-07 03:47:13 EDT
Description of problem:

We experience once in a while that we mount the wrong filesystem from our
fileservers using /n. We get a directory on the / filesystem and not a directory
on the /q/lfs0_11 filesystem as expected.

To be precise we do a: 

cd /n/file.host.name.here/q/lfs0_11
ls

Sometimes we get the contents of the /q/lfs0_11 filesystem and sometimes we get
nothing (the contents of /q/lfs0_11 directory under the / filesystem).

The details:

The fileserver now runs RHEL4
The client runs Solaris9 or RHEL3 (possibly also RHEL4, could not get it to
error while writing this bugreport, but have received reports from users that is
also fails.)


We ran RHEL3 on the server before the summer and had no problems, so it is
somehow related to the upgrade from RHEL3 to RHEL4 on the servers.

/etc/exports on the server:
      @adm(rw,no_root_squash,insecure,sync)
/var       @adm(rw,no_root_squash,insecure,sync)
/tmp       @adm(rw,no_root_squash,insecure,sync)
/q/disk_0       @nadm(rw,insecure,sync) @adm(rw,no_root_squash,insecure,sync)
/q/disk_1       @nadm(rw,insecure,sync) @adm(rw,no_root_squash,insecure,sync)
/q/lfs0_0       @nadm(rw,insecure,sync) @adm(rw,no_root_squash,insecure,sync)
/q/lfs0_1       @nadm(rw,insecure,sync) @adm(rw,no_root_squash,insecure,sync)

More entries similar to above (except number in the end) has been removed.

We naturally get no errors in /var/log/messages on the servers.

Any suggestions on what to do. What has changed between RHEL3 and RHEL4 that can
trigger this behaviour? 

Version-Release number of selected component (if applicable):
nfs-utils-1.0.6-46

How reproducible:
Sometimes, but not always

Steps to Reproduce:
1. cd /n/file.host.name.here/q/lfs0_11
2. ls 
3. continue by doing 1. again but exchange lfs0_11 with lfs0_10 etc. until ls
gives an empty result
  
Actual results:


Expected results:


Additional info:
Comment 1 Mikael M. Hansen 2005-10-19 08:43:45 EDT
Any help on this? 

What has changed since RHEL3?
Comment 2 Steve Dickson 2005-10-20 10:30:58 EDT
Everything... :-\ 

Try adding the 'no_subtree_check' and 'nohide' export
options to see how it effect things... 
Comment 3 Steve Dickson 2006-10-03 08:41:17 EDT
did the no_subtree_check and/or nohide export options help?
Comment 5 Mikael M. Hansen 2006-12-21 06:02:52 EST
Nope. We still get the underlying file system. from time to time.

But as we have changed most of the software to mount directly from the server
using its own mount point I really cannot tell if the problem is still there.

Just close it. 

Note You need to log in before you can comment on or make changes to this bug.