Bug 170100 - logwatch reports incomplete disk usage
logwatch reports incomplete disk usage
Status: CLOSED DUPLICATE of bug 152419
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: logwatch (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-07 05:13 EDT by Christian Iseli
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-07 06:14:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Iseli 2005-10-07 05:13:05 EDT
Description of problem:
When reporting the current disk status, the zz-disk_space utility does:
df -h | grep '^/dev/'

However, df sometimes reports the partition usage on two lines, e.g.:
/dev/mapper/Volume00-LogVol00
                      112G   65G   43G  61% /database

Thus the mailed report only contains the first line, which is not very useful...

Version-Release number of selected component (if applicable):
logwatch-5.2.2-1

How reproducible:
Always, if you have a long path to the device entry

Steps to Reproduce:
1. Create a partition with a long path for its device name
2. Mount it
3. Wait for logwatch's email
  
Actual results:
/dev/mapper/Volume00-LogVol00


Expected results:
dev/mapper/Volume00-LogVol00
                      112G   65G   43G  61% /database


Additional info:
I'd suggest removing the "|grep" part...  or using df -hl (or -hP, because
the P seems to force the output on a single line).
Comment 1 Ivana Varekova 2005-10-07 06:14:59 EDT

*** This bug has been marked as a duplicate of 152419 ***

Note You need to log in before you can comment on or make changes to this bug.