Bug 1701057 - resolv.conf isn't properly populated on first boot [NEEDINFO]
Summary: resolv.conf isn't properly populated on first boot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RHCOS
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.1.0
Assignee: Ben Howard
QA Contact: Micah Abbott
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-17 21:51 UTC by Alex Crawford
Modified: 2019-06-04 10:47 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:47 UTC
Target Upstream Version:
smilner: needinfo? (behoward)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:55 UTC
Github coreos ignition-dracut pull 78 'None' 'closed' '30ignition: remove initramfs networking' 2019-11-20 16:45:16 UTC

Description Alex Crawford 2019-04-17 21:51:13 UTC
Description of problem:

When booting an RHCOS instance on Azure, /etc/resolv.conf is populated with information about the build environment. After a reboot, it is properly populated with information derived from Azure DHCP.


Version-Release number of selected component (if applicable):


How reproducible:

Always


Steps to Reproduce:
1. Boot instance on Azure
2. Observe /etc/resolv.conf
3. Reboot the instance
4. Observe /etc/resolv.conf

Actual results:

$ cat /etc/resolv.conf 
# Generated by NetworkManager
search virt.pnr.lab.eng.rdu2.redhat.com
nameserver 10.0.2.3

<reboot>

$ cat /etc/resolv.conf
# Generated by NetworkManager
search p4lbnhjmffruzemjwvnywik2tf.xx.internal.cloudapp.net
nameserver 168.63.129.16


Expected results:

$ cat /etc/resolv.conf
# Generated by NetworkManager
search p4lbnhjmffruzemjwvnywik2tf.xx.internal.cloudapp.net
nameserver 168.63.129.16

<reboot>

$ cat /etc/resolv.conf
# Generated by NetworkManager
search p4lbnhjmffruzemjwvnywik2tf.xx.internal.cloudapp.net
nameserver 168.63.129.16


Additional info:

Comment 7 errata-xmlrpc 2019-06-04 10:47:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.