Bug 17011 - (Almost) all XFree 3.3.6 drivers selected in custom upgrade
Summary: (Almost) all XFree 3.3.6 drivers selected in custom upgrade
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard: Florence RC-1
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-27 20:14 UTC by Andrea Borgia
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-09 00:51:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrea Borgia 2000-08-27 20:14:07 UTC
How to reproduce: setup 6.2, use Xconfigurator to setup a valid config and confirm you have only your driver installed.
Then, do an upgrade and choose to customize the list: all X drivers save S3, S3V, VGA16 and W32 are selected.
(if you don't customize, you end up with all those selected being installed)

Comment 1 Michael Fulbright 2000-08-29 16:13:34 UTC
Please reproduce Brock.

Comment 2 Brock Organ 2000-08-29 21:58:05 UTC
verified this behavior ... thanks for the report!

Here are the XFree packages in 6.2: (rpm -qa | grep -i xfree)

XFree86-3.3.6-20                                                                
XFree86-libs-3.3.6-20                                                           
XFree86-xfs-3.3.6-20                                                            
XFree86-75dpi-fonts-3.3.6-20                                                    
XFree86-Mach64-3.3.6-20                                                                                        

Here are the XFree packages after upgrade:

XFree86-libs-4.0.1-1                                                             
XFree86-xfs-4.0.1-1                                                              
XFree86-3DLabs-3.3.6-33                                                          
XFree86-8514-3.3.6-33                                                            
XFree86-devel-4.0.1-1                                                            
XFree86-FBDev-3.3.6-33                                                           
XFree86-Mach32-3.3.6-33                                                          
XFree86-Mach8-3.3.6-33                                                           
XFree86-P9000-3.3.6-33                                                           
XFree86-tools-4.0.1-1                                                            
XFree86-xdm-4.0.1-1                                                              
XFree86-4.0.1-1                                                                  
XFree86-75dpi-fonts-4.0.1-1                                                      
XFree86-AGX-3.3.6-33                                                             
XFree86-doc-4.0.1-1                                                              
XFree86-I128-3.3.6-33                                                           
XFree86-Mach64-3.3.6-33                                                          
XFree86-Mono-3.3.6-33                                                            
XFree86-S3-3.3.6-33                                                              
XFree86-twm-4.0.1-1

Comment 3 Michael Fulbright 2000-10-24 16:15:14 UTC
This is caused by how the XFree86 packages were built for the 7.0 product.

We will have to revisit this issue in the next release.

Comment 4 Glen Foster 2001-01-11 21:11:31 UTC
This defect is considered MUST-FIX for Florence Gold release

Comment 5 Glen Foster 2001-01-25 00:44:20 UTC
This defect has been re-classified as MUST-FIX for Florence Release-Candidate #1

Comment 6 Erik Troan 2001-02-09 00:51:34 UTC
fixed in rpm CVS

Comment 7 Brock Organ 2001-02-12 19:53:36 UTC
verified fix ... in a test upgrade, only 2 of the umpteen X Servers were
installed instead of all of them ... This should improve things ...



Note You need to log in before you can comment on or make changes to this bug.