Bug 1701162 - Bad filter conditions for the installed operators on web console
Summary: Bad filter conditions for the installed operators on web console
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-18 09:25 UTC by Jian Zhang
Modified: 2019-05-06 13:00 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-28 13:51:00 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jian Zhang 2019-04-18 09:25:49 UTC
Description of problem:
Could not find installed operator by following the navigation on the Web console.

Version-Release number of selected component (if applicable):
Cluster version is 4.0.0-0.nightly-2019-04-10-182914
[jzhang@dhcp-140-46 aws-cluster]$ oc get pods -n openshift-console console-6cf575cd8d-d66d2 -o yaml|grep image
    console.openshift.io/image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:13fe4ddb76846a03a4fe03603be9416fd0fb225688bc5990d460c5c4afcbb133
    image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:09d7bddf100ab95281f50dd15299694f58a67ccc1a78a2821cce7dd6005f36d8

console image version:
  io.openshift.build.commit.id=3ab27f0b383d338c622c4c6b4790390ad4a96a13

How reproducible:
always

Steps to Reproduce:
1. Create a project and install the `AMQ-streams` operator in it.
2. Catalog -> Operator Hub-> AMQ Streams(or your installed Operators) -> We can see the notes: "This Operator has been installed on the cluster. View it here." -> Click the `View it here` link. 


Actual results:
Could not find the installed Operators.

Expected results:
Could find the installed operators by following the navigation on the Web console.

Additional info:
I think the root cause is that filter strings is inappropriate in the search bar. For exmaple, the name of the `AMQ-Streams` csv is "amqstreams.v1.0.0", but the filter strings is "amq-streams"!

The same bug in previous version, but fixed at that time: https://bugzilla.redhat.com/show_bug.cgi?id=1686036

Comment 1 Samuel Padgett 2019-04-18 11:38:47 UTC
https://github.com/openshift/console/pull/1450

Comment 2 Samuel Padgett 2019-04-23 22:08:10 UTC
Note that the fix removes the name filter altogether. If there are other operators installed in the namespace, you'll see them when following the link. (This is better than sometimes incorrectly hiding the one you want.)

Comment 3 Yadan Pei 2019-04-28 06:23:23 UTC
1. Create a project and install the `AMQ-streams` operator in it.
2. Catalog -> Operator Hub-> AMQ Streams(or your installed Operators) -> We can see the notes: "This Operator has been installed on the cluster. View it here." -> Click the `View it here` link.
It will redirects to /k8s/ns/<namespace>/clusterserviceversions page, all operators installed in this namespace will be shown through this link.

According to comment 2, above scenario is working as intended.

Verified on

4.1.0-0.nightly-2019-04-25-121505
io.openshift.build.commit.url=https://github.com/openshift/console/commit/6ffcf1e550f72523d69ec04e2d4b45b8c0e682a0


Note You need to log in before you can comment on or make changes to this bug.