Bug 1701169 - UPI installer - lost content on Node page.
Summary: UPI installer - lost content on Node page.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Marek Libra
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-18 09:40 UTC by XiaochuanWang
Modified: 2019-06-04 10:47 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
node page goes wrong (265.06 KB, image/png)
2019-04-18 09:40 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:55 UTC

Description XiaochuanWang 2019-04-18 09:40:05 UTC
Created attachment 1556118 [details]
node page goes wrong

Description of problem:
Cluster admin check Nodes page, it can not to list the content.

Version-Release number of selected component (if applicable):
quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:09d7bddf100ab95281f50dd15299694f58a67ccc1a78a2821cce7dd6005f36d8


How reproducible:
Always

Steps to Reproduce:
1. Cluster admin check Nodes page, please check screenshot.


Actual results:
Failed to load the nodes. Please refer to screenshot.

TypeError: "n is null"
	M https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/node-chunk-23f79940626fb69bc3c8.min.js:1:2850
	beginWork https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/vendors~main-chunk-74c941872e3298b87233.min.js:107:50239
	o https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/vendors~main-chunk-74c941872e3298b87233.min.js:107:54823
	a https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/vendors~main-chunk-74c941872e3298b87233.min.js:107:55102
	x https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/vendors~main-chunk-74c941872e3298b87233.min.js:107:58045
	_ https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/vendors~main-chunk-74c941872e3298b87233.min.js:107:57588
	b https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/vendors~main-chunk-74c941872e3298b87233.min.js:107:57425
	m https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/vendors~main-chunk-74c941872e3298b87233.min.js:107:56804
	p https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/vendors~main-chunk-74c941872e3298b87233.min.js:107:56266
	enqueueSetState https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/vendors~main-chunk-74c941872e3298b87233.min.js:107:45545
	setState https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/vendors~main-chunk-74c941872e3298b87233.min.js:115:1653
	onStateChange https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/vendors~main-chunk-74c941872e3298b87233.min.js:56:39001
	notify https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/vendors~main-chunk-74c941872e3298b87233.min.js:91:155033
	notifyNestedSubs https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/vendors~main-chunk-74c941872e3298b87233.min.js:91:154646
	onStateChange https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/vendors~main-chunk-74c941872e3298b87233.min.js:56:39019
	m https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/vendors~main-chunk-74c941872e3298b87233.min.js:55:16812
	r https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/vendors~main-chunk-74c941872e3298b87233.min.js:91:85853
	dispatch https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/vendors~main-chunk-74c941872e3298b87233.min.js:91:10471
	c https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/main-chunk-78eecf2787841c9e2c05.min.js:1:342959
	c https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/main-chunk-78eecf2787841c9e2c05.min.js:1:342929
	i https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/main-chunk-78eecf2787841c9e2c05.min.js:1:340141
	i https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/main-chunk-78eecf2787841c9e2c05.min.js:1:339459
	s https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/main-chunk-78eecf2787841c9e2c05.min.js:1:339016
	a https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/vendors~main-chunk-74c941872e3298b87233.min.js:115:19565
	T https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/vendors~main-chunk-74c941872e3298b87233.min.js:115:19687
	c https://console-openshift-console.apps.gpei-vsp-0417.qe.devcluster.openshift.com/static/vendors~main-chunk-74c941872e3298b87233.min.js:115:18258

Expected results:
Should correctly load the nodes list.

Additional info:

Comment 1 Samuel Padgett 2019-04-18 11:22:56 UTC
https://github.com/openshift/console/pull/1449

Comment 2 XiaochuanWang 2019-04-23 02:50:28 UTC
Nodes page displays correctly.
Verified on 4.1.0-0.nightly-2019-04-22-005054
registry.svc.ci.openshift.org/ocp/release@sha256:3f3628cd9b694705cb0627ce72e61932df5d9938a291fabba1ed691230f7b548

Comment 4 errata-xmlrpc 2019-06-04 10:47:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.