Bug 1701255 - Keepalived logs errors on the undercloud when monitoring VIPs
Summary: Keepalived logs errors on the undercloud when monitoring VIPs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: 15.0 (Stein)
Assignee: Damien Ciabrini
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-18 13:52 UTC by Damien Ciabrini
Modified: 2019-09-26 10:49 UTC (History)
7 users (show)

Fixed In Version: puppet-tripleo-10.4.2-0.20190502220347.02cd12e.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:21:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 655421 0 None MERGED Fix keepalived VIP monitoring script 2020-05-13 03:27:58 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:21:48 UTC

Description Damien Ciabrini 2019-04-18 13:52:30 UTC
Description of problem:
When deploying an OSP15 undercloud, I can see errors logged by keepalived when it monitors the VIPs configured on the host:

2019-04-16T11:55:57.368030988+00:00 stderr F Tue Apr 16 11:55:57 2019: ------< VRRP Scripts >------
2019-04-16T11:55:57.368030988+00:00 stderr F Tue Apr 16 11:55:57 2019: VRRP Script = haproxy
2019-04-16T11:55:57.368030988+00:00 stderr F Tue Apr 16 11:55:57 2019: Command = '/usr/bin/test' '-S' '/var/lib/haproxy/stats' '&&' 'echo' 'show'
[...]
2019-04-16T11:55:57.371142270+00:00 stderr F Tue Apr 16 11:55:57 2019: Script `haproxy` now returning 2
2019-04-16T11:55:57.371142270+00:00 stderr F Tue Apr 16 11:55:57 2019: VRRP_Script(haproxy) failed (exited with status 2)

This is because the keepalived config uses the a script that has quoting issues and lacks call to /bin/sh:

vrrp_script haproxy {
  script "test -S /var/lib/haproxy/stats && echo "show info" | socat /var/lib/haproxy/stats stdio"
  interval 2
  weight 2
}

Note: Even if keepalived is still running, I don't think the VIP monitoring is still effective at this point.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Deploy an undercloud

Actual results:
keepalived logs errors

Expected results:
VIP probe should succeed

Additional info:

Comment 1 Damien Ciabrini 2019-04-24 13:13:32 UTC
Fix merged in Master (Train)
Review backported to Stein upstream [1]

[1] https://review.opendev.org/#/c/655421/

Comment 6 errata-xmlrpc 2019-09-21 11:21:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.