Bug 1701343 - HPA failing with unable to get metrics for resource cpu: no metrics returned from resource metrics API [NEEDINFO]
Summary: HPA failing with unable to get metrics for resource cpu: no metrics returned ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.1.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: 4.1.0
Assignee: Sergiusz Urbaniak
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-18 17:16 UTC by Jeremy Eder
Modified: 2019-06-04 10:47 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:47 UTC
Target Upstream Version:
weinliu: needinfo? (jeder)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:55 UTC
Github coreos kube-prometheus pull 80 None None None 2019-04-23 12:21:32 UTC
Github openshift cluster-monitoring-operator pull 332 None None None 2019-04-23 15:47:35 UTC

Comment 7 Weinan Liu 2019-05-07 07:00:10 UTC
Confirmed with OnlineQE team, there's no available 4.1 OSD Cluster available for testing the issue, I'll update the status to Modified and waiting the cluster ready.

@Naveen Malik,
I think the fix should not be shipped with https://errata.devel.redhat.com/advisory/38252, how can we requesting removing it from the errata?

@Jeremy Eder, and @Sergiusz Urbaniak,
as it's an issue for OSD only (not on OCP), can we move it to Product:OpenShiftOnline?

Comment 9 Weinan Liu 2019-05-08 07:29:18 UTC
As per Sergiusz's comment,  it's a fix on cluster role in the cluster monitoring operator (not related with HPA), updating the QA Contact to Junqi from monitoring team

Comment 13 errata-xmlrpc 2019-06-04 10:47:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.