Bug 1701449 - Many "couldn't get SNTP reply" errors in node-exporter container logs
Summary: Many "couldn't get SNTP reply" errors in node-exporter container logs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.1.0
Assignee: Frederic Branczyk
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-19 04:45 UTC by Junqi Zhao
Modified: 2019-06-04 10:47 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
node-exporter container logs (259.19 KB, text/plain)
2019-04-19 04:45 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:55 UTC

Description Junqi Zhao 2019-04-19 04:45:00 UTC
Created attachment 1556342 [details]
node-exporter container logs

Description of problem:
Many "couldn't get SNTP reply" errors in node-exporter container logs
eg:
$ oc -n openshift-monitoring logs node-exporter-spc65 -c node-exporter
time="2019-04-19T02:00:05Z" level=error msg="ERROR: ntp collector failed after 0.000279s: couldn't get SNTP reply: read udp 127.0.0.1:60401->127.0.0.1:123: read: connection refused" source="collector.go:132"
time="2019-04-19T02:00:05Z" level=error msg="ERROR: ntp collector failed after 0.002058s: couldn't get SNTP reply: read udp 127.0.0.1:58233->127.0.0.1:123: read: connection refused" source="collector.go:132"
time="2019-04-19T02:00:35Z" level=error msg="ERROR: ntp collector failed after 0.005542s: couldn't get SNTP reply: read udp 127.0.0.1:47830->127.0.0.1:123: read: connection refused" source="collector.go:132"
time="2019-04-19T02:00:35Z" level=error msg="ERROR: ntp collector failed after 0.000153s: couldn't get SNTP reply: read udp 127.0.0.1:45740->127.0.0.1:123: read: connection refused" source="collector.go:132

details see the attached logs file, it seems it does not affect the function

Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-04-18-190537

How reproducible:
Always

Steps to Reproduce:
1. Check node-exporter container logs
2.
3.

Actual results:
Many "couldn't get SNTP reply" errors in node-exporter container logs

Expected results:
Should not have this error

Additional info:

Comment 1 Frederic Branczyk 2019-04-24 14:03:28 UTC
PR opened to fix this https://github.com/openshift/cluster-monitoring-operator/pull/334

Comment 2 Frederic Branczyk 2019-04-25 12:29:45 UTC
The PR has merged.

Comment 4 Junqi Zhao 2019-04-28 01:48:27 UTC
issue is fixed
payload: 4.1.0-0.nightly-2019-04-25-121505

Comment 6 errata-xmlrpc 2019-06-04 10:47:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.