Bug 1701462 - router deployment is not updated after removing tolerations from ingresscontroller
Summary: router deployment is not updated after removing tolerations from ingresscontr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Miciah Dashiel Butler Masters
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-19 06:27 UTC by Hongan Li
Modified: 2019-06-04 10:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:58 UTC
Github openshift cluster-ingress-operator pull 213 None None None 2019-04-19 20:56:31 UTC

Description Hongan Li 2019-04-19 06:27:35 UTC
Description of problem:
Tolerations and taints of router can work after adding tolerations to ingresscontroller,
But after removing tolerations from ingresscontroller, the route deployment is not updated and still contains tolerations setting. 

Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-04-18-190537

How reproducible:
100%

Steps to Reproduce:
1. edit ingresscontroller and adding tolerations as below:
$ oc -n openshift-ingress-operator edit ingresscontroller/default
spec:
  nodePlacement:
    tolerations:
    - effect: NoExecute
      operator: Exists
      key: router
2. check router deployment and pods
$ oc -n openshift-ingress get deployment -o yaml | grep toleration -A 3

3. edit ingresscontroller and remove the tolerations

Actual results:
step2: the deployment and pod of router contains the tolerations
step3: same to step2

Expected results:
in step3, router pod should be redeployed and the toleration should be removed. 

Additional info:

Comment 1 Miciah Dashiel Butler Masters 2019-04-19 20:56:31 UTC
PR: https://github.com/openshift/cluster-ingress-operator/pull/213

Comment 3 Hongan Li 2019-04-24 03:13:46 UTC
verified with 4.1.0-0.nightly-2019-04-23-223857 and issue has been fixed.

Comment 5 errata-xmlrpc 2019-06-04 10:47:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.