Bug 1701585 - nmcli does not bring up vlan interfaces
Summary: nmcli does not bring up vlan interfaces
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager
Version: 7.7
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Beniamino Galvani
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-19 17:36 UTC by suresh kumar
Modified: 2019-08-06 13:17 UTC (History)
9 users (show)

Fixed In Version: NetworkManager-1.18.0-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 13:16:56 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2302 None None None 2019-08-06 13:17:10 UTC

Description suresh kumar 2019-04-19 17:36:06 UTC
Description of problem:

Customer has a requirement of restarting NetworkManager. But it created issues like creating duplicate policy rules for every restart. So we suggested below method to restart NetworkManager


nmcli networking off
systemctl restart NetworkManager
nmcli networking on


But this does not bring up vlan interfaces:


Version-Release number of selected component (if applicable):

 NetworkManager-1.12.0-10.el7_6.x86_64.


How reproducible:
 Always


Steps to Reproduce:

# cat ifcfg-eth0.10 
TYPE="Vlan"
PHYSDEV="eth0"
ONBOOT="yes"
IPADDR=192.168.123.102
NETMASK=255.255.255.0
VLAN="yes"
VLAN_ID=10
NAME=eth0.10


//Before:
# nmcli co show
NAME     UUID                                  TYPE      DEVICE  
eth0     5fb06bd0-0bb0-7ffb-45f1-d6edd65f3e03  ethernet  eth0    
eth0.10  2dadfa26-8bfc-790a-38d4-6a0151de29d3  vlan      eth0.10 


# nmcli networking off;systemctl restart NetworkManager; nmcli networking on

//Now
# nmcli co show
NAME     UUID                                  TYPE      DEVICE 
eth0     5fb06bd0-0bb0-7ffb-45f1-d6edd65f3e03  ethernet  eth0   
eth0.10  2dadfa26-8bfc-790a-38d4-6a0151de29d3  vlan      --     <<<<<



Actual results:
nmcli  does not bring up vlan interface.

Expected results:
nmcli bring up vlan interface.

Comment 3 Thomas Haller 2019-05-01 13:05:54 UTC
fixed upstream.

Comment 6 Vladimir Benes 2019-05-17 08:57:25 UTC
covered by new version of @vlan_on_bond_autoconnect
https://gitlab.freedesktop.org/NetworkManager/NetworkManager-ci/commit/7bba94ee52fa9865f8d2e83e27081cd3a68999e3

Comment 8 errata-xmlrpc 2019-08-06 13:16:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2302


Note You need to log in before you can comment on or make changes to this bug.