Bug 170169 - up2date refuses to install pdksh, claiming it is already updated
up2date refuses to install pdksh, claiming it is already updated
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-07 17:22 EDT by Bob Plankers
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-11 13:37:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Plankers 2005-10-07 17:22:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
Hello,

up2date refuses to install pdksh under both AS 3 and AS 4, claiming that it is installed already. RPM disagrees, claiming that it is not installed, and a survey of the machine indicates that there is no /bin/ksh.

An example:

$ rpm -q pdksh
package pdksh is not installed

$ sudo up2date pdksh

Fetching Obsoletes list for channel: rhel-i386-as-3...
########################################

Fetching Obsoletes list for channel: rhel-i386-as-3-extras...
########################################

Fetching Obsoletes list for channel: rhel-3-as-i386-rhds-2...
########################################

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
pdksh                                   5.2.14         21                i386  


Testing package set / solving RPM inter-dependencies...
########################################

The following packages you requested are already updated:
pdksh


Version-Release number of selected component (if applicable):
up2date-4.4.44-3

How reproducible:
Always

Steps to Reproduce:
1. "rpm -q pdksh" to determine that it isn't installed, or "rpm --erase pdksh"
2. "up2date pdksh"
3.
  

Actual Results:  Fetching Obsoletes list for channel: rhel-i386-as-3...
########################################

Fetching Obsoletes list for channel: rhel-i386-as-3-extras...
########################################

Fetching Obsoletes list for channel: rhel-3-as-i386-rhds-2...
########################################

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
pdksh                                   5.2.14         21                i386  


Testing package set / solving RPM inter-dependencies...
########################################

The following packages you requested are already updated:
pdksh

Expected Results:  It should have installed pdksh for me.

Additional info:
Comment 1 Bob Plankers 2005-10-10 19:41:01 EDT
An "up2date -p" does not correct the problem, either. Tried that today.
Comment 2 Bob Plankers 2005-10-11 13:37:24 EDT
Folks,

It appears that this is related to our Satellite server installation. All of our
hosts update from the Satellite, whereas the Satellite updates from the true
RHN. As a consequence the Satellite server's up2date can retrieve and install
pdksh, whereas the other hosts cannot. We are running Satellite 3.7.1. I just
discovered all of this.

I am going to close this for right now, since it does not appear to be truly an
up2date problem. I have opened a support case with Red Hat Technical Support
about this.

Sorry about that.

Note You need to log in before you can comment on or make changes to this bug.