Bug 1701693 - [abrt] simple-ccsm: show_popup(): Widgets.py:957:show_popup:TypeError: __init__() got multiple values for argument 'parent'
Summary: [abrt] simple-ccsm: show_popup(): Widgets.py:957:show_popup:TypeError: __init...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ccsm
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:93161c536c1a93f6b4df9e8ac03...
: 1708978 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-20 19:30 UTC by yucef sourani
Modified: 2019-05-22 11:31 UTC (History)
4 users (show)

Fixed In Version: ccsm-0.8.16-2.fc30 ccsm-0.8.16-2.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-22 01:39:53 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (874 bytes, text/plain)
2019-04-20 19:30 UTC, yucef sourani
no flags Details
File: cgroup (331 bytes, text/plain)
2019-04-20 19:30 UTC, yucef sourani
no flags Details
File: cpuinfo (1.25 KB, text/plain)
2019-04-20 19:30 UTC, yucef sourani
no flags Details
File: environ (1.55 KB, text/plain)
2019-04-20 19:30 UTC, yucef sourani
no flags Details
File: mountinfo (3.66 KB, text/plain)
2019-04-20 19:30 UTC, yucef sourani
no flags Details
File: namespaces (129 bytes, text/plain)
2019-04-20 19:30 UTC, yucef sourani
no flags Details
File: open_fds (1.21 KB, text/plain)
2019-04-20 19:30 UTC, yucef sourani
no flags Details

Description yucef sourani 2019-04-20 19:30:36 UTC
Version-Release number of selected component:
simple-ccsm-0.8.16-1.fc30

Additional info:
reporter:       libreport-2.10.0
cmdline:        /usr/bin/python3 /usr/bin/simple-ccsm
crash_function: show_popup
exception_type: TypeError
executable:     /usr/bin/simple-ccsm
interpreter:    python3-3.7.3-1.fc30.x86_64
kernel:         5.0.7-300.fc30.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
Widgets.py:957:show_popup:TypeError: __init__() got multiple values for argument 'parent'

Traceback (most recent call last):
  File "/usr/lib/python3.7/site-packages/ccm/Widgets.py", line 957, in show_popup
    mouse=True, modal=False)
TypeError: __init__() got multiple values for argument 'parent'

Local variables in innermost frame:
self: <Widgets.GlobalEdgeSelector object at 0x7f7230dbf1b0 (ccm+Widgets+GlobalEdgeSelector at 0x55a6c5c35b10)>
widget: <Widgets.GlobalEdgeSelector object at 0x7f7230dbf1b0 (ccm+Widgets+GlobalEdgeSelector at 0x55a6c5c35b10)>
edge: 'TopLeft'
event: <Gdk.EventButton object at 0x7f7230db6e08 (void at 0x55a6c65d8290)>
comboBox: <Gtk.ComboBoxText object at 0x7f7230d77a20 (GtkComboBoxText at 0x55a6c5cedd40)>
i: 12
setting: <compizconfig.Setting object at 0x7f7230d567c8>
text: 'Scale: Initiate Window Picker For Windows on Current Output'

Comment 1 yucef sourani 2019-04-20 19:30:40 UTC
Created attachment 1556709 [details]
File: backtrace

Comment 2 yucef sourani 2019-04-20 19:30:41 UTC
Created attachment 1556710 [details]
File: cgroup

Comment 3 yucef sourani 2019-04-20 19:30:44 UTC
Created attachment 1556711 [details]
File: cpuinfo

Comment 4 yucef sourani 2019-04-20 19:30:46 UTC
Created attachment 1556712 [details]
File: environ

Comment 5 yucef sourani 2019-04-20 19:30:48 UTC
Created attachment 1556713 [details]
File: mountinfo

Comment 6 yucef sourani 2019-04-20 19:30:50 UTC
Created attachment 1556714 [details]
File: namespaces

Comment 7 yucef sourani 2019-04-20 19:30:52 UTC
Created attachment 1556715 [details]
File: open_fds

Comment 8 yucef sourani 2019-04-22 07:32:33 UTC
https://gitlab.com/compiz/ccsm/merge_requests/28

Comment 9 Jaroslav Škarvada 2019-05-13 15:41:20 UTC
*** Bug 1708978 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2019-05-13 16:09:59 UTC
ccsm-0.8.16-2.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-ddbfded8e8

Comment 11 Fedora Update System 2019-05-13 16:17:59 UTC
ccsm-0.8.16-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-15760cfa0b

Comment 12 Fedora Update System 2019-05-14 01:54:02 UTC
ccsm-0.8.16-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-ddbfded8e8

Comment 13 Fedora Update System 2019-05-14 04:26:16 UTC
ccsm-0.8.16-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-15760cfa0b

Comment 14 Fedora Update System 2019-05-22 01:39:53 UTC
ccsm-0.8.16-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2019-05-22 11:31:19 UTC
ccsm-0.8.16-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.