Bug 170185 - sensors -s unreliable & BEEP problem
Summary: sensors -s unreliable & BEEP problem
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: lm_sensors   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: David Lawrence
URL: http://www2.lm-sensors.nu/~lm78/readt...
Whiteboard:
Keywords:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-10-08 13:10 UTC by Nicolas Mailhot
Modified: 2015-03-05 01:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-11 11:02:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 5576 None None None Never

Description Nicolas Mailhot 2005-10-08 13:10:29 UTC
lm_sensors is very conservative with its fan divisor settings. It assumes low
resolution sensors which is less and less the case on modern hardware.

As a result the fan divisor value must be set with sensors -s to get a
meaningful fan reading. This operation seems unreliable - it works but not
always the first time, especially early in the boot process

sensors -s will not retry to set parameters in the background - you have to
script the retries
lm_sensors will no wait for the setting to succeed to monitor fan values. It
will compare the fan readings to the alert levels while they're still garbage
(because the divisor is still wrong)

As a result on my hardware linux boot = continuous LOUD alert beep. The
workaround is to do a 
/usr/bin/sensors -s
/usr/bin/sensors (sometimes you have to do a read for the setting to be taken
into account)

manually after the boot sequence which will set the divisor and shut up the
alert (put into the rc.local, only beeps a few minutes now)

This means you can't boot linux with other people around (office space, home box
late in the evening)

I had this problem with my previous mobo too (Via chipset, now nVidia one) -
except it was not beeping on alert, so the sensors reads were being silently wrong.

Please add a few retries and sleeps in the sensors init script. The current one
is fast but unreliable

Comment 1 Nicolas Mailhot 2005-10-27 18:32:54 UTC
See also: http://www2.lm-sensors.nu/~lm78/readticket.cgi?ticket=2095

Comment 2 Nicolas Mailhot 2005-11-11 11:02:53 UTC
After investigation upstream, the problem is some configuration directives in
sensors.conf were not in the order expected by sensors. And libsensors is too
dumb to reorder them by itself.

-> Long-term fix : enhance libsensors to automatically reorder configuration
directives or at least warn when they're not in canonical order


Note You need to log in before you can comment on or make changes to this bug.