Bug 1701958 - python2-pwntools fails to install due to missing dependencies
Summary: python2-pwntools fails to install due to missing dependencies
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pwntools
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: W. Michael Petullo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F31FailsToInstall PY2FTBI
TreeView+ depends on / blocked
 
Reported: 2019-04-22 14:40 UTC by Miro Hrončok
Modified: 2019-08-31 07:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-31 07:39:30 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2019-04-22 14:40:07 UTC
$ mock -r fedora-rawhide-x86_64 install python2-pwntools
...
Error: 
 Problem: package python2-pwntools-3.12.2-1.fc31.noarch requires python2.7dist(intervaltree) < 3.0, but none of the providers can be installed
  - package python2-pwntools-3.12.2-1.fc31.noarch requires python2-intervaltree, but none of the providers can be installed
  - conflicting requests
  - nothing provides python2.7dist(sortedcontainers) needed by python2-intervaltree-2.1.0-4.fc30.noarch
  - nothing provides python2-sortedcontainers needed by python2-intervaltree-2.1.0-4.fc30.noarch



Please fix this or remove the package.

Comment 1 Miro Hrončok 2019-04-29 20:06:19 UTC
A week has passed and this bug is still in the NEW state and the package does not install.

Please fix this or indicate that you are working ona  fix by setting the state to ASSIGNED.

After 3 such reminders, this package may be orphaned.

https://fedoraproject.org/wiki/Changes/F31_Mass_Python_2_Package_Removal#Removing_non-installable_packages_from_the_distro

Thanks

Comment 2 W. Michael Petullo 2019-05-03 15:56:55 UTC
Pwntools does not yet support Python 3, but it appears close. See https://github.com/Gallopsled/pwntools/issues/529.

Comment 3 Miro Hrončok 2019-05-06 14:17:45 UTC
In preparation for the Python 2 EOL, we are removing all non-installable Python 2 packages:
https://fedoraproject.org/wiki/Changes/F31_Mass_Python_2_Package_Removal#Removing_non-installable_packages_from_the_distro

This bug is still in the NEW state and the package does not install. Please indicate you are working on a fix by setting the state to ASSIGNED. When this bug is four weeks in the NEW state, the package may be orphaned.

Note that you don't have to actually fix this right now, setting the bug to ASSIGNED will just mark this as being worked on, so I'll know it is being taken care of. If this happens too quickly, feel free to reach to me any time for help (with specific problems).

(My previous comment might have come across a bit too aggressive. I'm sorry, that was not my intention.)

(If you know for sure this package shall be removed, consider doing it.)

Thank You!

Comment 4 Miro Hrončok 2019-07-22 16:05:03 UTC
This has been ASSIGNED for 2 months and 2 weeks, but the problem is still relevant:

$ mock -r fedora-rawhide-x86_64 init
$ mock -r fedora-rawhide-x86_64 install python2-pwntools
Problem: conflicting requests
 - nothing provides python2-intervaltree needed by python2-pwntools-3.12.2-1.fc31.noarch
 - nothing provides python2.7dist(intervaltree) < 3.0 needed by python2-pwntools-3.12.2-1.fc31.noarch

What is the status? The upstream issue has not been updated since.

Comment 5 W. Michael Petullo 2019-07-22 17:58:19 UTC
I am still waiting for pwntools to move to Python 3. There is little I can do until the upstream project finishes the port.

Comment 6 Ben Cotton 2019-08-13 16:59:43 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 7 Ben Cotton 2019-08-13 18:58:13 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 8 Miro Hrončok 2019-08-21 15:47:05 UTC
See https://fedoraproject.org/wiki/Changes/F31_Mass_Python_2_Package_Removal#Removing_non-installable_packages_from_the_distro

"Packages still failing to install due to a missing Python 2 dependency will be retired at Beta Freeze, assuming they have a Bugzilla bug open for at least 2 weeks. The package maintainer may postpone this retirement to the Final Freeze by promising to fix it until then."

Let me know if this package shall not be retired yet. The beta freeze is at 2019-08-29, the final freeze is at 2019-10-08.

Comment 9 Miro Hrončok 2019-08-28 11:17:39 UTC
Retired the package in master and f31. Let me know if you want me review it once (if) it is added back.

Comment 10 Miro Hrončok 2019-08-30 11:57:32 UTC
Requesting a freeze exception based on https://pagure.io/fesco/issue/2216#comment-593925

Comment 11 Adam Williamson 2019-08-30 16:11:04 UTC
Unproposing per https://pagure.io/fesco/issue/2216#comment-594033 . Please only propose bugs where an update was actually pending before the 29th, unless there is a more urgent reason why that package specifically should get an FE.

Comment 12 Miro Hrončok 2019-08-31 07:39:30 UTC
I've verified that the package is gone from the fedora repo. Thanks and sorry for panicking.


Note You need to log in before you can comment on or make changes to this bug.