Bug 170199 - resolution change on logout doesn't reset virtual X/Y offset
resolution change on logout doesn't reset virtual X/Y offset
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-10-08 18:26 EDT by Jon Burgess
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-05 12:13:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.85 KB, text/plain)
2005-10-08 18:28 EDT, Jon Burgess
no flags Details
/var/log/Xorg.0.log (48.43 KB, text/plain)
2005-10-08 18:30 EDT, Jon Burgess
no flags Details

  None (edit)
Description Jon Burgess 2005-10-08 18:26:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
If i'm using a non-default resolution (e.g. 640x480 via ctrl-alt-+) and logout then login page appears in the default 1024x768. It seems this resolution switch is incomplete, because if I move the mouse towards the edges of the screen then it still pans as-if it were still in a virtual mode. Once the screen pans left-right/up-down it will actually lock on to a fixed 0,0 offset and the problem disapeears.



Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-54

How reproducible:
Always

Steps to Reproduce:
1. Configure your X-server with multiple resolutions, e.g. add 640x480
2. use ctrl-alt-plus/minus to switch to 640x480.
3. Move the mouse off one corner of the screen and the virtual desktop will pan over to that corner.
4. logout
  

Actual Results:  After logout the reolution switches back to default (in my case 1024x768) and sometimes the screen appears off-centre or part of it contains the old (pre-logout) desktop display.

Moving the mouse to the left, right, top, bottom borders of the display causes the screen to pan as-if it were still operating in a virtual mode. Once this has been done the screen locks on to the zero offset position and the problem goes away.



Expected Results:  On logout the screen should lock to 0,0 virtual offset and not move around when the mouse gets near the edge.


Additional info:

The problem exists on fc4 and rawhide (xorg-x11-6.8.2-54). It also seems to occur if xrandr is used to switch to a low resolution and is then followed by a logout.

The problem seems to be limited to the resolution switch on logout. If I use ctr-alt-+ to switch back to the default resolution then the problem does not occur.
Comment 1 Jon Burgess 2005-10-08 18:28:08 EDT
Created attachment 119735 [details]
xorg.conf
Comment 2 Jon Burgess 2005-10-08 18:30:39 EDT
Created attachment 119736 [details]
/var/log/Xorg.0.log
Comment 3 Mike A. Harris 2006-02-05 12:13:22 EST
Fedora development upgraded to X11R7.0 release candidates in late November,
and the current release in Fedora devel is the X11R7.0 final release.  Please
update to the latest development packages and the problem persists, please
file a bug report in X.Org bugzilla at http://bugs.freedesktop.org in the
"xorg" component.  Once you've filed a bug in X.Org bugzilla, if you paste
the URL in a comment here, we will track the bug upstream and review any
fixes that become available for consideration in future updates.

Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.