Bug 1702072 - unable to run fix_auth on database with "stack too deep"
Summary: unable to run fix_auth on database with "stack too deep"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.9.7
Hardware: All
OS: All
high
high
Target Milestone: GA
: 5.10.4
Assignee: Keenan Brock
QA Contact: Jaroslav Henner
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On: 1696237
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-22 21:42 UTC by Satoe Imaishi
Modified: 2019-11-01 16:57 UTC (History)
5 users (show)

Fixed In Version: 5.10.4.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1696237
Environment:
Last Closed: 2019-05-21 05:46:56 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1247 None None None 2019-05-21 05:47:04 UTC

Comment 2 Keenan Brock 2019-04-23 16:31:34 UTC
Satoe rocks - already backported it

Comment 3 CFME Bot 2019-04-24 19:47:05 UTC
New commit detected on ManageIQ/manageiq/hammer:

https://github.com/ManageIQ/manageiq/commit/58bf5843bf92e394639fe05d8b75aaa2948d27a8
commit 58bf5843bf92e394639fe05d8b75aaa2948d27a8
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Fri Apr  5 11:24:48 2019 -0400
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Fri Apr  5 11:24:48 2019 -0400

    Merge pull request #18631 from kbrock/recursive_passwords

    fix_auth now handles recursive settings

    (cherry picked from commit 365c1a02de560bf7ce9e173c61986de08e19baee)

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1702072

 lib/vmdb/settings_walker.rb | 3 +-
 spec/lib/vmdb/settings_spec.rb | 77 +-
 2 files changed, 53 insertions(+), 27 deletions(-)

Comment 5 errata-xmlrpc 2019-05-21 05:46:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1247

Comment 6 Jaroslav Henner 2019-11-01 16:57:12 UTC
Keeping the qe_test_coverage- as I was unable to reproduce


Note You need to log in before you can comment on or make changes to this bug.