Bug 17021 - Some older binaries won't run (no such file or directory)
Summary: Some older binaries won't run (no such file or directory)
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-28 02:24 UTC by Geoff Reedy
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-28 02:25:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Geoff Reedy 2000-08-28 02:24:59 UTC
Older binaries X11 quake for instance will not run on redhat-7.0 beta.
They at least try to execute with /usr/i386-glibc21-linux/lib/ld-linux.so.2
but with /lib/ld-linux.so.2 they just give ld-linux.so.2 a seg fault.  

The glibc-2.1.3 compat loader gives a libm.so.5 not found because of the
elimination of libc 5 compatability.  It seems to me this is a rather bad
move, since there are still some programs out there that are binary only
and linked against libc 5.  I suppose I can just install the compat package
from 6.2, but this is a pain.

Comment 1 Jakub Jelinek 2000-09-01 10:33:29 UTC
If you really want to run libc5 applications, you really need to install compat from 6.2,
I don't see any point in shipping libc5 compatibility forever in the distribution.
glibc is used in the distribution for 3 years.


Note You need to log in before you can comment on or make changes to this bug.