Bug 170224 - java runtime libs and files do not belong to any package
java runtime libs and files do not belong to any package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: java-1.4.2-gcj-compat (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-09 09:45 EDT by Jasper O. Hartline
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-03 20:15:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jasper O. Hartline 2005-10-09 09:45:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
Two files in the Fedora stock install do not belong to a package namely these:
/usr/lib/jvm/java-1.4.2-gcj-1.4.2.0/jre/lib/i386/libjawt.so
/usr/bin/java

This causes any .rpm files needing to be installed to fail knowing there is no libjawt.so in any package in the rpmdb.


Version-Release number of selected component (if applicable):
java-1.4.2-gcj-compat-1.4.2.0-40jpp_31rh.FC4.1

How reproducible:
Always

Steps to Reproduce:
1.Attempt to install a package
2.Package says failed: libjawt.so is needed by <packagename>
3.File a bug
  

Actual Results:  rpm and the package complain about dependent libjawt.so

Expected Results:  The .rpm file would install successfully.
This could be said about many .rpm files I believe.

Additional info:

Need INFO, else a workaround since libjawt.so doesn't belong to a package.
Perhaps also just keep libjawt.so a real file not a symlink.
Comment 1 Thomas Fitzsimmons 2006-02-03 20:15:14 EST
None of the alternatives symlinks in /usr/bin are owned by any package.  However
libjawt.so is now owned by java-1.4.2-gcj-compat in Rawhide.  Closing.

Note You need to log in before you can comment on or make changes to this bug.