Bug 170229 - Python-powered Configuration Utilities Should Have Backtrace on Exception Reporting to Fedora's Bugzilla Server
Python-powered Configuration Utilities Should Have Backtrace on Exception Rep...
Status: CLOSED DUPLICATE of bug 170228
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-09 12:52 EDT by Matt T. Proud
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-09 12:53:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt T. Proud 2005-10-09 12:52:20 EDT
Description of problem:
This bug has just been filed under this component, because I remember this 
utility crashing considerably during system installations; but the concept 
should apply to all of Fedora's Python-power utilities.

When a Python-powered Fedora configuration utility crashes, it just gives one 
the option the debug or to examine a backtrace. It might be useful if, upon a 
crash, the application could use some mechanism similar to GNOME's Bugbuddy 
infrastructure to allow for bug reporting, including the backtrace and useful 
variables, back to the Fedora project.

Additional info:
If this would help cut-down on the number of spurious problems encountered in 
the configuration utilities, great; it is necessary for the project.
Comment 1 Matt T. Proud 2005-10-09 12:53:44 EDT
Opera had an oops.

*** This bug has been marked as a duplicate of 170228 ***

Note You need to log in before you can comment on or make changes to this bug.