Bug 1702449 - oc client platform information is empty
Summary: oc client platform information is empty
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.1.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-23 19:34 UTC by Peter Ruan
Modified: 2019-06-04 10:48 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:48:03 UTC

Description Peter Ruan 2019-04-23 19:34:27 UTC
Description of problem:
oc client does not display the client platform.  This occurs for all supported platforms (see output below).  Trevor found that it's been broken since the output format changed in http://github.com/openshift/origin/commit/8c90407567709252c88896a7af6cbb96c2a5297a

Version-Release number of selected component (if applicable):

4.1.0-rc.0 (but older version of oc also exhibit this behavior)

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
Windows
=======
PS C:\Users\ocp-q> oc version
Client Version: version.Info{Major:"4", Minor:"1+", GitVersion:"v4.1.0-201904211700+843a3fa-dirty", GitCommit:"843a3fa", GitTreeState:"", BuildDate:"2019-04-21T23:42:21Z", GoVersion:"", Compiler:"", Platform:""}
Server Version: version.Info{Major:"1", Minor:"13+", GitVersion:"v1.13.4+c9ccf35", GitCommit:"c9ccf35", GitTreeState:"clean", BuildDate:"2019-04-23T08:10:24Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"linux/amd64"}

Linux
======
pruan@dhcp-91-104 ~/workspace/bushslicer (master)$ oc version                                                                                                                   
Client Version: version.Info{Major:"4", Minor:"1+", GitVersion:"v4.1.0", GitCommit:"1016bda6b", GitTreeState:"", BuildDate:"2019-04-09T04:48:59Z", GoVersion:"", Compiler:"", Platform:""}
Server Version: version.Info{Major:"1", Minor:"13+", GitVersion:"v1.13.4+c9ccf35", GitCommit:"c9ccf35", GitTreeState:"clean", BuildDate:"2019-04-23T08:10:24Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"linux/amd64"}


MacOS
=======
pruan@MacBook-Pro ~/Downloads $ oc version                                                                                                                       
Client Version: version.Info{Major:"4", Minor:"1+", GitVersion:"v4.1.0-201904211700+843a3fa-dirty", GitCommit:"843a3fa", GitTreeState:"", BuildDate:"2019-04-21T23:42:21Z", GoVersion:"", Compiler:"", Platform:""}
Server Version: version.Info{Major:"1", Minor:"13+", GitVersion:"v1.13.4+c9ccf35", GitCommit:"c9ccf35", GitTreeState:"clean", BuildDate:"2019-04-23T08:10:24Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"linux/amd64"}


Expected results:


Additional info:

Comment 1 Peter Ruan 2019-04-24 08:09:06 UTC
@xxia, Clayton indicated in slack to open a bug to master team

Comment 2 Maciej Szulik 2019-04-24 11:41:03 UTC
PR in https://github.com/openshift/origin/pull/22650

Comment 3 zhou ying 2019-04-26 04:59:31 UTC
Confirmed with latest oc , the issue has fixed:
[root@dhcp-140-138 ~]# oc version
Client Version: version.Info{Major:"4", Minor:"1+", GitVersion:"v4.1.0", GitCommit:"44e89e525", GitTreeState:"clean", BuildDate:"2019-04-25T22:42:17Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"linux/amd64"}
Server Version: version.Info{Major:"1", Minor:"13+", GitVersion:"v1.13.4+5c41ab6", GitCommit:"5c41ab6", GitTreeState:"clean", BuildDate:"2019-04-24T20:42:36Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"linux/amd64"}


[root@Mac-Slave-1 ~]$ oc version
Client Version: version.Info{Major:"4", Minor:"1+", GitVersion:"v4.1.0", GitCommit:"bbefc2cc4", GitTreeState:"clean", BuildDate:"2019-04-26T03:10:49Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"darwin/amd64"}

Comment 4 zhou ying 2019-04-28 02:26:12 UTC
oc version
Client Version: version.Info{Major:"4", Minor:"1+", GitVersion:"v4.1.0", GitCommit:"27a00af64", GitTreeState:"clean", BuildDate:"2019-04-27T17:00:43Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"windows/amd6
4"}
Server Version: version.Info{Major:"1", Minor:"13+", GitVersion:"v1.13.4+438fe5b", GitCommit:"438fe5b", GitTreeState:"clean", BuildDate:"2019-04-25T11:05:03Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"linu
x/amd64"}

Comment 6 errata-xmlrpc 2019-06-04 10:47:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.