Bug 1702529 - DNS operator's status for DEGRADED type is reported empty
Summary: DNS operator's status for DEGRADED type is reported empty
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: DNS
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Daneyon Hansen
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-24 03:33 UTC by Hongan Li
Modified: 2019-06-04 10:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:48:03 UTC
Github openshift cluster-dns-operator pull 99 None None None 2019-04-24 18:22:40 UTC

Description Hongan Li 2019-04-24 03:33:12 UTC
Description of problem:
DNS operator's status for DEGRADED type is reported empty when running `oc get clusteroperators.config.openshift.io`

Version-Release number of selected component (if applicable):
4.1.0-0.nightly-2019-04-23-223857

How reproducible:
100%

Steps to Reproduce:
1. $ oc get co
2.
3.

Actual results:
$ oc get co
NAME                                 VERSION                             AVAILABLE   PROGRESSING   DEGRADED   SINCE
authentication                       4.1.0-0.nightly-2019-04-23-223857   True        False                    77m
cloud-credential                     4.1.0-0.nightly-2019-04-23-223857   True        False                    88m
cluster-autoscaler                   4.1.0-0.nightly-2019-04-23-223857   True        False                    88m
console                              4.1.0-0.nightly-2019-04-23-223857   True        False         False      80m
dns                                  4.1.0-0.nightly-2019-04-23-223857   True        False                    88m
image-registry                       4.1.0-0.nightly-2019-04-23-223857   True        False                    81m
ingress                              4.1.0-0.nightly-2019-04-23-223857   True        False                    81m


Expected results:
DEGRADED should not be empty

Additional info:
see also: https://bugzilla.redhat.com/show_bug.cgi?id=1702087

Comment 2 Hongan Li 2019-04-25 02:04:23 UTC
verified with 4.1.0-0.nightly-2019-04-24-221323 and issue has been fixed.

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.1.0-0.nightly-2019-04-24-221323   True        False         9m17s   Cluster version is 4.1.0-0.nightly-2019-04-24-221323

$ oc get co/dns
NAME   VERSION                             AVAILABLE   PROGRESSING   DEGRADED   SINCE
dns    4.1.0-0.nightly-2019-04-24-221323   True        False         False      21m

$ oc get co/dns -o yaml
<---snip--->
status:
  conditions:
  - lastTransitionTime: 2019-04-25T01:40:27Z
    status: "False"
    type: Degraded
  - lastTransitionTime: 2019-04-25T01:40:27Z
    status: "False"
    type: Progressing

Comment 4 errata-xmlrpc 2019-06-04 10:47:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.