Bug 1702548 - module javapackages-tools fails to install on platform:f31
Summary: module javapackages-tools fails to install on platform:f31
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora Modules
Classification: Fedora
Component: javapackages-tools
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mikolaj Izdebski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F31FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2019-04-24 06:06 UTC by Mikolaj Izdebski
Modified: 2019-04-26 00:14 UTC (History)
2 users (show)

Fixed In Version: javapackages-tools-201801-2820190425234444.819b5873
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-26 00:14:53 UTC


Attachments (Terms of Use)

Description Mikolaj Izdebski 2019-04-24 06:06:46 UTC
Description of problem:
Module javapackages-tools, stream 201801 does not install on platform:f31

Steps to Reproduce:
1. odcs create module javapackages-tools:201801
2. curl -o /etc/yum.repos.d/odcs-252.repo https://odcs.fedoraproject.org/composes/latest-odcs-252-1/compose/Temporary/odcs-252.repo
3. dnf module enable javapackages-tools:201801
4. dnf install maven-local

Actual results:
Error: 
 Problem: package maven-local-5.3.0-3.module_f28+3695+340f1066.noarch requires javapackages-local = 5.3.0-3.module_f28+3695+340f1066, but none of the providers can be installed
  - package javapackages-local-5.3.0-3.module_f28+3695+340f1066.noarch requires python3-javapackages = 5.3.0-3.module_f28+3695+340f1066, but none of the providers can be installed
  - conflicting requests
  - nothing provides python(abi) = 3.6 needed by python3-javapackages-5.3.0-3.module_f28+3695+340f1066.noarch

Comment 1 Mat Booth 2019-04-25 09:43:35 UTC
FWIW this prevents me from building Eclipse on F31.

IMO, since javapackages-tools is a "build only" module and users won't normally be installing it on workstations, it's not a big deal if there is no python bytecode shipped in this module. I'm not a python wonk so there could be a better way :-)

Comment 2 Mikolaj Izdebski 2019-04-25 17:31:51 UTC
The current draft plan is to:
- move Python modules out of /usr/lib/python3.X/site-packages/ to a private location somewhere under /usr/share/
- do not bytecompile the modules so that they keep working with any Python 3 minor version
- implement basic tests for javapackages-tools module that will make sure that the module is installable on all platforms (bug #1684621)

But I need to confirm what are Fedora rules for Python bytecode generation and for installing Python modules in non-standard locations - I don't want to violate any packaging guidelines.

Comment 3 Mikolaj Izdebski 2019-04-25 23:18:02 UTC
POST-ed for testing in MBI.

Comment 4 Mikolaj Izdebski 2019-04-26 00:14:53 UTC
This should be fixed in the latest javapackages-tools module, stream 201801.


Note You need to log in before you can comment on or make changes to this bug.