Bug 17026 - Segmentation fault after "put abc*" in ftp
Segmentation fault after "put abc*" in ftp
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ftp (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-28 03:09 EDT by Bill Huang
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-29 03:36:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Huang 2000-08-28 03:09:38 EDT
When using command "put" to put files instead of "mput" in ftp-0.17-6, ftp
shows 
"Segmentation fault (core dumped)" and quits from ftp.

Re-compile the ftp source rpm in debug mode, it shows the messages below
when using "put" files instead of "mput".
---
ftp> put station22.*
(no debugging symbols found)...(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
chunk_free (ar_ptr=0x40232da0, p=0x807289c) at malloc.c:3068
3068	malloc.c: No such file or directory.
(gdb)
Comment 1 Bill Huang 2000-08-29 03:36:54 EDT
Two points updated on this report:

1. Although recompiled ftp with option -g, the -s option was not removed when
make install, so messages (no debugging symbols found) were displayed. 

2. If using /usr/bin/ftp, it was OK to use "put aaa*" command on ftp, it showed 
"Segmentation fault" when using /usr/kerberos/bin/ftp

ldd these two files, we can find:

[root@station8 test]# ldd /usr/bin/ftp
        libreadline.so.4.1 => /usr/lib/libreadline.so.4.1 (0x40025000)
        libncurses.so.5 => /usr/lib/libncurses.so.5 (0x4004b000)
        libc.so.6 => /lib/libc.so.6 (0x4008d000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
[root@station8 test]# ldd /usr/kerberos/bin/ftp 
        libgssapi_krb5.so.2 => /usr/kerberos/lib/libgssapi_krb5.so.2
(0x40018000)
        libkrb4.so.2 => /usr/kerberos/lib/libkrb4.so.2 (0x4002d000)
        libkrb5.so.3 => /usr/kerberos/lib/libkrb5.so.3 (0x40044000)
        libdes425.so.3 => /usr/kerberos/lib/libdes425.so.3 (0x400ac000)
        libk5crypto.so.3 => /usr/kerberos/lib/libk5crypto.so.3 (0x400b0000)
        libcom_err.so.3 => /usr/kerberos/lib/libcom_err.so.3 (0x400c5000)
        libutil.so.1 => /lib/libutil.so.1 (0x400d5000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x400d8000)
        libresolv.so.2 => /lib/libresolv.so.2 (0x40105000)
        libc.so.6 => /lib/libc.so.6 (0x40117000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
[root@station8 test]#
Comment 2 Bernhard Rosenkraenzer 2001-01-20 18:29:21 EST
Can't reproduce this in the current release.

Note You need to log in before you can comment on or make changes to this bug.