Bug 1702621 - 'dnf provides' wildcard search doesn't show the actual matched file
Summary: 'dnf provides' wildcard search doesn't show the actual matched file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marek Blaha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-24 09:45 UTC by Kamil Páral
Modified: 2019-08-31 01:38 UTC (History)
9 users (show)

Fixed In Version: dnf-4.2.5-4.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-31 01:38:42 UTC


Attachments (Terms of Use)

Description Kamil Páral 2019-04-24 09:45:45 UTC
Description of problem:
DNF used to show the file it matched with a wildcard provides search. Now it doesn't, which makes it far less useful when there are multiple matches. Example:


$ sudo dnf provides '**/yum.py'
Last metadata expiration check: 0:02:18 ago on Wed 24 Apr 2019 11:38:41 AM CEST.
ansible-2.7.10-1.fc29.noarch : SSH-based configuration management, deployment, and task execution system
Repo        : @System
Matched from:
Other       : **/yum.py

python3-tracer-0.7.1-2.fc29.noarch : Common files for tracer
Repo        : @System
Matched from:
Other       : **/yum.py

sos-3.7-1.fc29.noarch : A set of tools to gather troubleshooting information from a system
Repo        : @System
Matched from:
Other       : **/yum.py

gdeploy-2.0.11-1.fc29.noarch : Tool to deploy and manage GlusterFS cluster
Repo        : updates-testing
Matched from:
Other       : **/yum.py

ansible-2.7.10-1.fc29.noarch : SSH-based configuration management, deployment, and task execution system
Repo        : updates
Matched from:
Other       : **/yum.py

python2-tracer-0.7.1-2.fc29.noarch : Common files for tracer
Repo        : updates
Matched from:
Other       : **/yum.py

python3-tracer-0.7.1-2.fc29.noarch : Common files for tracer
Repo        : updates
Matched from:
Other       : **/yum.py

sos-3.7-1.fc29.noarch : A set of tools to gather troubleshooting information from a system
Repo        : updates
Matched from:
Other       : **/yum.py

...


The 'Matched from' line seems to be unintentionally blank. Please show the actual file that matched the query, so that people don't need to package by package and look into them to figure out which file matched.

Thank you.


Version-Release number of selected component (if applicable):
dnf-4.2.2-2.fc29.noarch

How reproducible:
always

Steps to Reproduce:
1. dnf provides **/somefile
2. see output not showing the matched file, just the pattern
3.

Comment 1 Marek Blaha 2019-04-30 06:10:40 UTC
PR https://github.com/rpm-software-management/dnf/pull/1389 should fix the issue.
Meanwhile as a workaround, you can use '*/yum.py' pattern which works fine.

Comment 2 Kamil Páral 2019-04-30 11:05:37 UTC
Interesting. It used to be the case that '*' matched a single path segment (file/directory) and '**' matched multiple path segments. The behavior changed, it seems. Thanks for the workaround.

Comment 3 Fedora Update System 2019-08-14 07:23:52 UTC
FEDORA-2019-d4b6ede072 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d4b6ede072

Comment 4 Fedora Update System 2019-08-16 20:12:16 UTC
dnf-4.2.5-4.fc29, dnf-plugins-extras-4.0.4-2.fc29, libdnf-0.31.0-6.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d4b6ede072

Comment 5 Fedora Update System 2019-08-31 01:38:42 UTC
dnf-4.2.5-4.fc29, dnf-plugins-extras-4.0.4-2.fc29, libdnf-0.31.0-6.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.