Bug 170272 - cannot update already installed packages with up2date
cannot update already installed packages with up2date
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
Beth Nackashi
:
Depends On:
Blocks: 191074 191079
  Show dependency treegraph
 
Reported: 2005-10-10 09:14 EDT by Andreas Bock
Modified: 2013-01-10 03:48 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-20 17:24:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of "up2date -u" (6.59 KB, text/plain)
2005-10-10 09:17 EDT, Andreas Bock
no flags Details
solving the problem (1.18 KB, text/plain)
2005-10-11 03:22 EDT, Andreas Bock
no flags Details
Output of up2date -vv cpp (11.37 KB, text/plain)
2006-01-26 05:30 EST, Peter Wainwright
no flags Details

  None (edit)
Description Andreas Bock 2005-10-10 09:14:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.2 (like Gecko)

Description of problem:
Updating my system with up2date fails because it tries to update already 
installed packages. 
 
Trying to recreate the RPM (rm /var/lib/rpm/__db*; rpm --rebuilddb) and 
up2date (up2date -p) databases does not help. Even removing the only non 
Redhat package (pine by Dag Wieers) does not help. 
 

Version-Release number of selected component (if applicable):
up2date-4.4.50-4

How reproducible:
Always

Steps to Reproduce:
1. start up2date -u  
2.  
3.  
    

Actual Results:  see attachment  

Expected Results:  up2date should resolve dependencies and update the system 

Additional info:
Comment 1 Andreas Bock 2005-10-10 09:17:52 EDT
Created attachment 119773 [details]
Output of "up2date -u"
Comment 2 Suzanne Hillman 2005-10-10 11:04:41 EDT
Which packages is it trying to update, even though they are already uptodate?

Please provide the output from this command, if you could.
Comment 3 Andreas Bock 2005-10-11 03:22:18 EDT
Created attachment 119793 [details]
solving the problem
Comment 4 Andreas Bock 2005-10-11 03:25:28 EDT
Please look at my 1st attachment!

But I solved the problem! Every package marked as already installed was
installed twice! Removing the older instance solved the problem.

Please, can anyone tell me, why does up2date install packages twice?
Comment 5 Andreas Bock 2005-10-11 03:36:47 EDT
Houston, we have a new problem :-/

After installation of packages started we se the following:

Installing...
   1:udev                   ########################################### [100%]
   2:mkinitrd               ########################################### [100%]
   3:initscripts            ########################################### [100%]
   4:openssh                ########################################### [100%]
   5:glibc-kernheaders      ########################################### [100%]
   6:glibc-headers          ########################################### [100%]
   7:glibc-devel            ########################################### [100%]
   8:gcc                    ########################################### [100%]
   9:vixie-cron             ########################################### [100%]
  10:gcc-c++                ########################################### [100%]
  11:gcc-g77                ########################################### [100%]
  12:openssh-server         ########################################### [100%]
  13:system-config-printer  ########################################### [100%]
  14:xinetd                 ########################################### [100%]
  15:sudo                   ########################################### [100%]
  16:slocate                ########################################### [100%]
  17:pdksh                  ########################################### [100%]

and nothing else!
Running top in a second windows shows:

top - 09:33:04 up 21:52,  2 users,  load average: 4.02, 3.52, 2.27
Tasks:  90 total,   4 running,  86 sleeping,   0 stopped,   0 zombie
Cpu(s):  0.0% us, 25.0% sy,  0.0% ni, 74.9% id,  0.1% wa,  0.0% hi,  0.0% si
Mem:  15966556k total,  1479704k used, 14486852k free,   116676k buffers
Swap:  4080456k total,        0k used,  4080456k free,  1163628k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
13837 root      18   0 54416 1224  588 R 99.9  0.0  17:07.40 useradd
14763 root      16   0  5284  908  688 R  0.3  0.0   0:00.24 top


Someone in another bug stopped ypbind to solve the problem. Trying so was to
late, I am also unable to "kill" or "kill -9" the useradd process. Maybe this is
the reason why anything went wrong. Let me tell you, it's a 4 CPU Sun V40z.

Please excuse my german accent :-/
Comment 6 Andreas Bock 2005-10-11 04:24:33 EDT
on a 2nd identical maschine I stoped ypbind befor using "up2date -u":

...
  16:sudo                   ########################################### [100%]
  17:slocate                ########################################### [100%]
  18:pdksh                  ########################################### [100%]
  19:nscd                   ########################################### [100%]
  20:nfs-utils              ########################################### [100%]
...

and the process ended successfull. Maybe the postinstall script of pdksh or nscd
tries to add a new user.

Some times ago I was able to automaticaly update my systems every night. I think
it would'nt be a good idea to stop this and update them manualy. Or maybe i
should stop ypbind every time befor running up2date.

Comment 7 Suzanne Hillman 2005-10-11 11:47:16 EDT
Apologies for not noticing the attachment. 

As far as updating twice, it's hard to be sure from the output given, but that
may relate to multilib packages, since this is an x86_64 machine. x86_64 is one
of the archs which has i386 packages in addition to those which go with the
architecture, so that may have been what was going on. Not positive, however.

For the later problem you ran into, this appears to be the same problem as that
reported in bug 170087, which is being investigated.
Comment 8 Peter Wainwright 2006-01-26 05:29:20 EST
I have also found that up2date often attempts to install already installed
packages and fails.  And, in at least one case, I have managed to track
down why.  Consider this output (attached).

Trying to update cpp alone fails because cpp requires a matching gcc version.
The dependency solver then considers the dependency gcc->cpp.  cpp is already
marked for installation, so (__dependencies) it tries to add gcc.  It also
marks for installation anything that obsoletes gcc - namely compat-libgcc-296.
There are two problems with this. FIRST (non-fatal) that compat-libgcc-296
only obsoletes gcc 2.96, it should not be considered here (gcc 3.4.3).
SECOND (and this is the killer), compat-libgcc-296 is up-to-date, so when it
is added to the transaction set, it causes the "already installed"
error.

Frankly the more I look at the internals of up2date the hairier it seems.


Peter Wainwright
Comment 9 Peter Wainwright 2006-01-26 05:30:38 EST
Created attachment 123710 [details]
Output of up2date -vv cpp
Comment 13 Fanny Augustin 2006-04-10 20:41:46 EDT
Blocking rhnupr4u4 and rhnupr3u8 to track the progress of the release
Comment 14 Fanny Augustin 2006-04-13 15:53:35 EDT
Moving bugs to the CanFix List
Comment 15 Fanny Augustin 2006-05-08 15:36:17 EDT
This bug did not make the code freeze and it will not be fiixed during this
release cycle.  Re-aligning bug to the next release
Comment 16 Fanny Augustin 2006-05-08 16:10:45 EDT
This bug did not make the code freeze.  It will not be fixed in this releasee 
Reea ligning to the next one.
Comment 18 James Bowes 2006-11-20 17:24:23 EST
I'm unable to reproduce this on RHEL 4 x86_86 with up2date-4.4.69-23

Note You need to log in before you can comment on or make changes to this bug.