Bug 1702724 - tuned doesn't react to SIGHUP when wrong profile has been selected
Summary: tuned doesn't react to SIGHUP when wrong profile has been selected
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned
Version: 7.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Robin Hack
Katerina Nemcova
URL:
Whiteboard:
: 1774645 (view as bug list)
Depends On:
Blocks: 1757052 1780577
TreeView+ depends on / blocked
 
Reported: 2019-04-24 14:51 UTC by Robin Hack
Modified: 2020-09-29 19:37 UTC (History)
7 users (show)

Fixed In Version: tuned-2.11.0-9.el7
Doc Type: Bug Fix
Doc Text:
.`tuned` no longer hangs on SIGHUP when a non-existent profile is selected When the `tuned` service receives the SIGHUP signal, it attempts to reload the profile. Prior to this update, `tuned` was unable to correctly handle situations when: * The `tuned` profile was set to a non-existent profile, or * The automatic profile selection mode was active and the recommended profile was non-existent. As a consequence, the `tuned` service became unresponsive and had to be restarted. This bug has been fixed, and the `tuned` service no longer hangs in the described scenarios. Note that the `tuned` behavior has changed with this update. Previously, when the user executed the `tuned-adm off` command and restarted the `tuned` service, `tuned` tried to load the recommended profile. Now, `tuned` loads no profile even if the recommended profile exists.
Clone Of:
Environment:
Last Closed: 2020-09-29 19:36:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github redhat-performance tuned pull 225 0 'None' closed Fix a hang on SIGHUP when the preset profile does not exist 2020-09-30 06:37:46 UTC
Red Hat Product Errata RHBA-2020:3884 0 None None None 2020-09-29 19:37:18 UTC

Description Robin Hack 2019-04-24 14:51:34 UTC
Description of problem:


Version-Release number of selected component (if applicable):
tuned-2.11.0-1.el7.noarch

How reproducible:
always

Steps to Reproduce:

# USE WRONG NONEXISTENT PROFILE
pushd /etc/tuned
echo "wrongdaybabenonexistentprofile" > active_profile
echo "manual" > profile_mode
popd

TUNED_PID=$(systemctl show -p MainPID tuned | cut -f2 -d'=')
kill -HUP $TUNED_PID

tuned-adm profile
...
No active profile selected

# TRY TO FIX PREVIOUS WRONG PROFILE
pushd /etc/tuned
echo "desktop" > active_profile
echo "manual" > profile_mode
popd

tuned-adm profile
...
No active profile selected


Actual results:
No active profile selected

Expected results:
Should load existing profile

Additional info:

Comment 2 Ondřej Lysoněk 2019-04-24 15:01:55 UTC
Good catch, thanks!

Comment 3 Ondřej Lysoněk 2019-11-27 10:43:46 UTC
*** Bug 1774645 has been marked as a duplicate of this bug. ***

Comment 5 Ondřej Lysoněk 2019-11-27 10:47:18 UTC
Upstream PR:
https://github.com/redhat-performance/tuned/pull/225

Comment 6 Ondřej Lysoněk 2019-12-02 11:49:31 UTC
(In reply to Ondřej Lysoněk from comment #5)
> Upstream PR:
> https://github.com/redhat-performance/tuned/pull/225

It got merged.

Comment 22 errata-xmlrpc 2020-09-29 19:36:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (tuned bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3884


Note You need to log in before you can comment on or make changes to this bug.