Bug 1702783 - Broken navigation from deleted operator CRD object
Summary: Broken navigation from deleted operator CRD object
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.1.0
Assignee: Alec Merdler
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1664187
TreeView+ depends on / blocked
 
Reported: 2019-04-24 18:25 UTC by Kevin Chung
Modified: 2019-05-31 15:45 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-31 15:45:19 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Kevin Chung 2019-04-24 18:25:40 UTC
Description of problem:

When I delete the custom objects that were created by an Installed Operator, the navigation after deletion brings me to the wrong URL.  The button to create the objects managed by the operator exists, but it does not populate with any of the predefined default values of the object since the URL is incorrect.  This appears to be an issue generically with any of the operators from OperatorHub, not specific to a particular operator.

Version-Release number of selected component (if applicable):

openshift-install v0.16.1
built from commit e3fceacc975953f56cb09931e6be015a36eb6075
OpenShift cluster version is 4.0.0-0.11

How reproducible:
Always

Steps to Reproduce:

1. Install OCP 4.0 cluster on AWS and log in as kubeadmin user.

2. Install an operator from Catalog -> OperatorHub.  For the purposes of reproducing this issue, I've selected the etcd operator.

3. Create custom objects from Catalog -> Installed Operators -> select an operator (i.e. etcd) -> etcd Cluster -> Create New.  Note how the default values of the object are prepopulated.

YAML:
apiVersion: etcd.database.coreos.com/v1beta2
kind: EtcdCluster
metadata:
  name: example
  annotations:
    etcd.database.coreos.com/scope: clusterwide
  namespace: mynamespace
spec:
  size: 3
  version: 3.2.13

4. Upon creation, the navigation properly brings me back to this link:
https://<myclustername>/k8s/ns/<mynamespace>/clusterserviceversions/etcdoperator.v0.9.4-clusterwide/etcd.database.coreos.com~v1beta2~EtcdCluster

5. Click into the created custom object (in this example, I have a cluster named 'example'):
https://<myclustername>/k8s/ns/<mynamespace>/clusterserviceversions/etcdoperator.v0.9.4-clusterwide/etcd.database.coreos.com~v1beta2~EtcdCluster/example

6. Delete the object via Actions -> Delete etcd Cluster, and the navigation now brings me to this link.  Note how the /clusterserviceversions/etcdoperator.v0.9.4-clusterwide has been omitted from the link.
https://<myclustername>/k8s/ns/<mynamespace>/etcd.database.coreos.com~v1beta2~EtcdCluster

7. Create a new object, and now the default values are no longer prepopulated.  In addition, the other tabs (Overview, YAML, Events, All Instances, and any operator actions) no longer are displayed.

YAML:
apiVersion: etcd.database.coreos.com/v1beta2
kind: EtcdCluster
metadata:
  name: example
  namespace: mynamespace
spec: {}

Actual results:

The navigation is broken following the deletion of objects created by an operator.  This results in the default values of a new request not being populated, and the other operator tabs not being displayed.

Expected results:

Following the deletion of an object managed by an operator, the navigation should take me back to the same link where I was previously viewing the operator.

Additional info:

Comment 1 Samuel Padgett 2019-04-24 20:23:37 UTC
I understand the usability concern. Having said that, I wouldn't call the navigation broken since the delete dialog does take you to the default list page for the resource, which is what it does for all resources. Since the behavior is functional and not a regression, marking low severity. We should still try to address this, however.

Comment 2 Samuel Padgett 2019-04-30 22:05:14 UTC
https://github.com/openshift/console/pull/1513

Comment 3 shahan 2019-05-05 04:27:17 UTC
after deleting cr using kebab actions, it will direct to page: https://$console-url/k8s/ns/hasha-pro1/clusterserviceversions/etcdoperator.v0.9.4/etcd.database.coreos.com~v1beta2~EtcdCluster

Verified this bug.
Console commit: 47f5e8e4a15303a15f138070753ab41c3e8fac3c
console image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:517fb0501e28769fa9edbf4fb228eac9c69c892d9f757892c3fe0219096a9df7


Note You need to log in before you can comment on or make changes to this bug.