Bug 1702875 - [cloud] cluster-autoscaler and machine-api operator status type has no value
Summary: [cloud] cluster-autoscaler and machine-api operator status type has no value
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Michael Gugino
QA Contact: sunzhaohua
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-25 03:41 UTC by sunzhaohua
Modified: 2019-06-04 10:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:48:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:48:12 UTC

Description sunzhaohua 2019-04-25 03:41:09 UTC
Description of problem:
Clusteroperator cluster-autoscaler and machine-api  status type should change from 'Failing' to 'Degraded'. 

https://github.com/openshift/api/pull/287/files

Version-Release number of selected component (if applicable):
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.1.0-0.nightly-2019-04-24-221323   True        False         18m     Cluster version is 4.1.0-0.nightly-2019-04-24-221323

How reproducible:
Always

Steps to Reproduce:
1. Deploy a new env on aws
2. Check clusteroperator status
3.

Actual results:
$ oc get clusteroperator
NAME                                 VERSION                             AVAILABLE   PROGRESSING   DEGRADED   SINCE
authentication                       4.1.0-0.nightly-2019-04-24-221323   True        False                    16m
cloud-credential                     4.1.0-0.nightly-2019-04-24-221323   True        False                    26m
cluster-autoscaler                   4.1.0-0.nightly-2019-04-24-221323   True        False                    26m
console                              4.1.0-0.nightly-2019-04-24-221323   True        False         False      18m
dns                                  4.1.0-0.nightly-2019-04-24-221323   True        False         False      26m
image-registry                       4.1.0-0.nightly-2019-04-24-221323   True        False                    20m
ingress                              4.1.0-0.nightly-2019-04-24-221323   True        False                    20m
kube-apiserver                       4.1.0-0.nightly-2019-04-24-221323   True        False         False      25m
kube-controller-manager              4.1.0-0.nightly-2019-04-24-221323   True        False         False      25m
kube-scheduler                       4.1.0-0.nightly-2019-04-24-221323   True        False         False      24m
machine-api                          4.1.0-0.nightly-2019-04-24-221323   True        False                    26m

$ oc get clusteroperator cluster-autoscaler -o yaml
...
status:
  conditions:
  - lastTransitionTime: "2019-04-25T02:31:00Z"
    message: at version 4.1.0-0.nightly-2019-04-24-221323
    status: "True"
    type: Available
  - lastTransitionTime: "2019-04-25T02:31:00Z"
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-04-25T02:31:00Z"
    status: "False"
    type: Failing

$ oc get clusteroperator machine-api -o yaml
...
status:
  conditions:
  - lastTransitionTime: "2019-04-25T02:31:20Z"
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-04-25T02:31:00Z"
    message: 'Cluster Machine API Operator is available at operator: 4.1.0-0.nightly-2019-04-24-221323'
    status: "True"
    type: Available
  - lastTransitionTime: "2019-04-25T02:31:00Z"
    status: "False"
    type: Failing

Expected results:
Status type changed from 'Failing' to 'Degraded'

Additional info:

Comment 1 Michael Gugino 2019-04-25 11:49:49 UTC
These are work in progress.

Comment 3 Michael Gugino 2019-04-26 00:44:21 UTC
CAO merged.

Comment 4 Michael Gugino 2019-04-26 16:41:58 UTC
MAO merged.

Comment 5 Jianwei Hou 2019-05-05 05:04:39 UTC
Verified in 4.1.0-0.nightly-2019-05-04-054221. Status changed from 'Failing' to 'Degraded'.

# oc get clusteroperator cluster-autoscaler -o yaml
...
  conditions:
  - lastTransitionTime: 2019-05-05T03:14:57Z
    message: at version 4.1.0-0.nightly-2019-05-04-054221
    status: "True"
    type: Available
  - lastTransitionTime: 2019-05-05T03:14:57Z
    status: "False"
    type: Progressing
  - lastTransitionTime: 2019-05-05T03:14:57Z
    status: "False"
    type: Degraded


# oc get clusteroperator machine-api -o yaml
...
status:
  conditions:
  - lastTransitionTime: 2019-05-05T03:15:33Z
    status: "False"
    type: Progressing
  - lastTransitionTime: 2019-05-05T03:14:57Z
    message: 'Cluster Machine API Operator is available at operator: 4.1.0-0.nightly-2019-05-04-054221'
    status: "True"
    type: Available
  - lastTransitionTime: 2019-05-05T03:14:57Z
    status: "False"
    type: Degraded

Comment 7 errata-xmlrpc 2019-06-04 10:48:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.