Bug 170300 - "--sslCACert" switch of "rhnreg_ks" adds semicolon to pathname
"--sslCACert" switch of "rhnreg_ks" adds semicolon to pathname
Status: CLOSED DUPLICATE of bug 169804
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Beth Nackashi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-10 12:31 EDT by terry.turner
Modified: 2008-05-09 13:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-10 14:10:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description terry.turner 2005-10-10 12:31:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
Matt Davis of Red Hat found that the "--sslCACert" switch of "rhnreg_ks" is buggy:
 
[root@erdos rhn]# cat up2date | grep sslCACert=
sslCACert=/usr/share/rhn/RHNS-CA-CERT
[root@erdos rhn]# /usr/sbin/rhnreg_ks --activationkey <###> --noSSLServerURL http://rhn.gatech.edu/XMLRPC --sslCACert /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT --serverUrl https://rhn.gatech.edu/XMLRPC
[root@erdos rhn]# cat up2date | grep sslCACert= sslCACert=/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT;
[root@erdos rhn]#                                ^
                           (Notice the semicolon at the end of the pathname.)

Version-Release number of selected component (if applicable):
up2date-4.4.5.6-2

How reproducible:
Always

Steps to Reproduce:
1. Register a client with the satellite using the "--sslCACert" switch of
"rhnreg_ks".
2. cat /etc/sysconfig/rhn/up2date | grep sslCACert=
3. Notice the semicolon at the end of the sslCACert pathname.


Actual Results:  /etc/sysconfig/rhn/up2date was incorrectly modified as follows:

sslCACert=/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT;

(Notice the semicolon at the end of the pathname.)


Expected Results:  sslCACert=/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT

(No semicolon at the end of the pathname above in /etc/sysconfig/rhn/up2date .)



Additional info:

This bug was first noticed because rhn-applet-gui could not connect to the
satellite server. (Other config files got corrupted because of this uber-bug.)
Comment 1 Matthew Davis 2005-10-10 14:10:59 EDT

*** This bug has been marked as a duplicate of 169804 ***

Note You need to log in before you can comment on or make changes to this bug.