Bug 1703018 - Registries: "undefined method `auto_complete_search_registries_path'"
Summary: Registries: "undefined method `auto_complete_search_registries_path'"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Container Management
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Released
Assignee: satellite6-bugs
QA Contact: Mirek Zalewski
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-25 10:09 UTC by Lukáš Hellebrandt
Modified: 2019-10-07 18:15 UTC (History)
17 users (show)

Fixed In Version: tfm-rubygem-foreman_docker-4.1.0.1-1
Doc Type: Known Issue
Doc Text:
This error can cause this deprecated feature to not work. This may be fixed in a future release.
Clone Of:
: 1726813 (view as bug list)
Environment:
Last Closed: 2019-08-06 14:37:33 UTC


Attachments (Terms of Use)
foreman-tail (47.02 KB, text/plain)
2019-04-25 10:09 UTC, Lukáš Hellebrandt
no flags Details
Hotfix (220.79 KB, patch)
2019-05-14 20:58 UTC, Christian Marineau
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2363 None None None 2019-08-06 14:37:43 UTC
Foreman Issue Tracker 25988 None None None 2019-05-03 11:49:28 UTC
Red Hat Knowledge Base (Solution) 4110151 None None None 2019-05-08 20:17:53 UTC

Description Lukáš Hellebrandt 2019-04-25 10:09:36 UTC
Created attachment 1558609 [details]
foreman-tail

Description of problem:
Going to Containers -> Registries in WebUI causes error:

"""
Oops, we're sorry but something went wrong undefined method `auto_complete_search_registries_path' for #<#<Class:0x00000000101ffbc0>:0x000000001326ffa8> Did you mean? auto_complete_search_filters_path auto_complete_search_subnets_path auto_complete_search_users_path auto_complete_search_usergroups_path auto_complete_search_realms_path auto_complete_search_settings_path auto_complete_search_roles_path auto_complete_search_environments_path auto_complete_search_parameters_path auto_complete_search_organizations_path auto_complete_search_media_path auto_complete_search_audits_path auto_complete_search_policies_path auto_complete_search_architectures_path auto_complete_search_smart_proxies_path auto_complete_search_hosts_path auto_complete_search_ansible_roles_path auto_complete_search_models_path auto_complete_search_ptables_path auto_complete_search_arf_reports_path auto_complete_search_hostgroups_path auto_complete_search_api_hosts_path auto_complete_search_domains_path auto_complete_search_locations_path auto_complete_search_http_proxies_path auto_complete_search_bookmarks_path auto_complete_search_fact_values_path auto_complete_search_lookup_keys_path
"""

Traceback attached.

Version-Release number of selected component (if applicable):
Reproduced on Satellite 6.5 snap 25

How reproducible:
Deterministic

Steps to Reproduce:
1. In WebUI, go to Containers -> Registries

Actual results:
Error

Expected results:
Registries page shown

Comment 3 Mirek Zalewski 2019-04-26 09:50:05 UTC
To clarify - it's not a problem that when you open page, little popup with error message appears. This error appears instead of page. Makes entire feature unusable.
I know docker management will be removed in future version of Satellite, but as far as I know, it is still supported in 6.5.

Comment 4 Brad Buckingham 2019-04-30 12:52:49 UTC
Similar to bug 1694187 on foreman_ansible.

Comment 5 Sanket Jagtap 2019-04-30 12:59:16 UTC
We need to pull in https://github.com/theforeman/foreman_docker/pull/215

Comment 8 Bryan Kearney 2019-05-03 14:02:01 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/25988 has been resolved.

Comment 10 Christian Marineau 2019-05-14 20:58:48 UTC
Created attachment 1568700 [details]
Hotfix

Comment 16 Mirek Zalewski 2019-07-12 10:35:19 UTC
Containers -> Registries page can be accessed. Registries can be created, searched and deleted.


Tested on:
Satellite 6.5.2 snap 1
pulp-server-2.18.1.1-1.el7sat.noarch
foreman-1.20.1.35-1.el7sat.noarch
tfm-rubygem-katello-3.10.0.53-1.el7sat.noarch
satellite-6.5.2-1.el7sat.noarch
tfm-rubygem-foreman_docker-4.1.0.1-1.el7sat.noarch

Comment 18 errata-xmlrpc 2019-08-06 14:37:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2363


Note You need to log in before you can comment on or make changes to this bug.