Bug 1703027 - Cluster operator storage does not have value for degraded
Summary: Cluster operator storage does not have value for degraded
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Bradley Childs
QA Contact: Liang Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-25 10:29 UTC by Liang Xia
Modified: 2019-06-04 10:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:48:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:48:12 UTC

Description Liang Xia 2019-04-25 10:29:24 UTC
Description of problem:
Clusteroperator DEGRADED field is checking with "Degraded", but storage is using "Failing"
https://github.com/openshift/api/pull/287/files

Version-Release number of selected component (if applicable):
4.1.0-0.nightly-2019-04-25-043235

How reproducible:
Always

Steps to Reproduce:
1. Deploy a new env on aws
2. Check clusteroperator status


Actual results:
$ oc get clusteroperator storage
NAME     VERSION                             AVAILABLE   PROGRESSING   DEGRADED   SINCE
storage  4.1.0-0.nightly-2019-04-25-002910   True        False                    45m


$ oc get co storage -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-04-25T09:28:21Z"
  generation: 1
  name: storage
  resourceVersion: "44624"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/storage
  uid: 777a0879-673c-11e9-8f73-02f2ab250226
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-04-25T10:14:24Z"
    status: "True"
    type: Available
  - lastTransitionTime: "2019-04-25T09:28:21Z"
    status: "False"
    type: Failing
  - lastTransitionTime: "2019-04-25T10:14:24Z"
    status: "False"
    type: Progressing
  extension: null
  relatedObjects: null
  versions:
  - name: operator
    version: 4.1.0-0.nightly-2019-04-25-043235


Expected results:
Clusteroperator storage show proper value for DEGRADED

Comment 1 Matthew Wong 2019-04-25 17:43:21 UTC
https://github.com/openshift/cluster-storage-operator/pull/29 has merged

Comment 4 Peter Ruan 2019-05-04 04:42:20 UTC
verified with 4.1.0-0.nightly-2019-05-03-145222

$oc get clusteroperator storage   
NAME      VERSION                             AVAILABLE   PROGRESSING   DEGRADED   SINCE
storage   4.1.0-0.nightly-2019-05-03-145222   True        False         False      6h20m

Comment 7 errata-xmlrpc 2019-06-04 10:48:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.