Bug 1703096 - Ansible roles page should say "import from foo.example.com"
Summary: Ansible roles page should say "import from foo.example.com"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Ansible
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: 6.7.0
Assignee: satellite6-bugs
QA Contact: Lukas Pramuk
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-25 13:45 UTC by Sean O'Keeffe
Modified: 2020-04-14 13:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-14 13:24:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot (9.51 KB, image/png)
2019-04-25 13:45 UTC, Sean O'Keeffe
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 27028 Normal Closed Ansible roles page should say "import from foo.example.com" 2020-09-11 13:04:15 UTC
Red Hat Product Errata RHSA-2020:1454 None None None 2020-04-14 13:24:22 UTC

Description Sean O'Keeffe 2019-04-25 13:45:10 UTC
Created attachment 1558694 [details]
Screenshot

Description of problem:
The button to import roles says "from foo.example.com" it should say "Import from foo.example.com" so the user knows what it actually does.


Version:
6.5 beta

How reproducible:
100%

Steps to Reproduce:
1. go to the Ansible Role page 
2. See button on the top right


Additional info:
Already fixed upstream as part of https://github.com/theforeman/foreman_ansible/commit/3c929f9787bb3eeb3431dd101bf6acb872f353e6

Comment 3 Brad Buckingham 2019-05-01 18:16:57 UTC
Same behavior observed on latest 6.5 builds (e.g. satellite-6.5.0-11.el7sat.noarch , foreman-1.20.1.34-1.el7sat.noarch , tfm-rubygem-foreman_ansible-2.2.14-2.el7sat.noarch , tfm-rubygem-foreman_ansible_core-2.1.2-2.el7sat.noarch)

Comment 4 Ondřej Pražák 2019-06-12 12:53:15 UTC
Created redmine issue https://projects.theforeman.org/issues/27028 from this bug

Comment 5 Bryan Kearney 2019-06-12 14:04:34 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/27028 has been resolved.

Comment 6 Lukas Pramuk 2020-03-04 15:56:32 UTC
VERIFIED.

@Satellite 6.7.0 Snap14

by following manual reproducer:

1) Navigate to Configure -> Ansible Roles and check the import button:

    [Import from <SATFQDN>] [(?) Documentation]

>>> the import button contains the word "import" (the action it does)

Comment 9 errata-xmlrpc 2020-04-14 13:24:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2020:1454


Note You need to log in before you can comment on or make changes to this bug.